Light icon for search box in light theme

VERIFIED FIXED in Firefox 29

Status

()

Firefox
Developer Tools: Inspector
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Optimizer, Assigned: bgrins)

Tracking

unspecified
Firefox 30
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox29 verified, firefox30 verified)

Details

(Whiteboard: [bugday-20140212])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

4 years ago
see the screenshot : https://pbs.twimg.com/media/BfdERUHCcAAdBq5.png:large

The search icon is not visible as it was meant for dark theme. We need to update this icon too.

(and uplift this)
(Reporter)

Updated

4 years ago
Flags: needinfo?(bgrinstead)
(Assignee)

Updated

4 years ago
Blocks: 966661
(Assignee)

Comment 1

4 years ago
Created attachment 8369434 [details] [diff] [review]
theme-search-icons.patch

Added light theme and 2x variants for the magnifying glass icon.  Added them to shared folder and removed the old one out of OS specific folders. Try push: https://tbpl.mozilla.org/?tree=Try&rev=e05a51c7b81d
Assignee: nobody → bgrinstead
Status: NEW → ASSIGNED
Attachment #8369434 - Flags: review?(vporof)
Flags: needinfo?(bgrinstead)
Comment on attachment 8369434 [details] [diff] [review]
theme-search-icons.patch

Review of attachment 8369434 [details] [diff] [review]:
-----------------------------------------------------------------

<3
Attachment #8369434 - Flags: review?(vporof) → review+
(Assignee)

Comment 3

4 years ago
Created attachment 8370006 [details] [diff] [review]
theme-search-icons.patch

Rebased patch
Attachment #8369434 - Attachment is obsolete: true
Attachment #8370006 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/f817fcb93e52
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 30
(Assignee)

Updated

4 years ago
Blocks: 957117
(Assignee)

Updated

4 years ago
No longer blocks: 957117
Depends on: 957117
(Assignee)

Comment 6

4 years ago
Comment on attachment 8370006 [details] [diff] [review]
theme-search-icons.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 957117
User impact if declined: Search box magnifier icon will be low contrast on the light DevTools theme
Testing completed (on m-c, etc.): On m-c since 02-04
Risk to taking this patch (and alternatives if risky): Low risk styling change for DevTools
String or IDL/UUID changes made by this patch:
Attachment #8370006 - Flags: approval-mozilla-aurora?
Attachment #8370006 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
status-firefox29: --- → affected
https://hg.mozilla.org/releases/mozilla-aurora/rev/794d8c507160
status-firefox29: affected → fixed
status-firefox30: --- → fixed

Comment 8

4 years ago
successfully verified the fixed on latest firefox 29 and 30.
status-firefox29: fixed → verified
status-firefox30: fixed → verified
Whiteboard: [bugday-20140212]

Updated

4 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.