Devtools themes - Light theme issues

RESOLVED FIXED

Status

()

Firefox
Developer Tools: Inspector
RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: ntim, Unassigned)

Tracking

29 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: meta)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8369102 [details]
Screenshot

Here's a list :
- sidemenu arrow is missing (I actually know why, it's because the file is named itemArrow-ltr.png while it should be itemArrow-ltr.svg, as it's an svg file)
- The addon command buttons are inverted
- The search icon is too light and nearly invisible
- Infobar is still dark

These are details and are less important :
- The tab active effect is horrible
- Some borders are too dark compared to the mockup
(Reporter)

Updated

4 years ago
Flags: needinfo?(bgrinstead)
(Reporter)

Comment 1

4 years ago
Other bugs in sidebar dock mode :
- Console, Inspector and network "side"bars have a black top border
Depends on: 966907
Depends on: 967033
> - sidemenu arrow is missing (I actually know why, it's because the file is
> named itemArrow-ltr.png while it should be itemArrow-ltr.svg, as it's an svg
> file)

Opened Bug 967033.

> - The addon command buttons are inverted

Yes, I've noticed this too.  I suppose we should not invert them, though if the addon author has uploaded a white icon because of the historically dark-only toolbars, it would not be visible.

> - The search icon is too light and nearly invisible

Bug 966907

> - Infobar is still dark

Since this is overlaid on web content (and not part of the normal devtools chrome), I think a case could be made for leaving it as dark.  I do see the point of using similar colors for consistency though.  There is also a bit of a challenge here - the main browser window (on which this is overlaid) is not aware of which devtools theme is applied.
Flags: needinfo?(bgrinstead)
(Reporter)

Comment 3

4 years ago
(In reply to Brian Grinstead [:bgrins] from comment #2)

> > - The addon command buttons are inverted
> 
> Yes, I've noticed this too.  I suppose we should not invert them, though if
> the addon author has uploaded a white icon because of the historically
> dark-only toolbars, it would not be visible.
> 
As you can see in the screenshot, the IE, Opera, Chrome icons are inverted, that the addon can't actually provide icons for them (it just takes the browser icon). Yes, if the author provides a white icon it can be a good idea to invert it, but no addon does it. I guess a good solution would be extend the toolbox tab functionality adding icon-light as parameter. (Same for the command icons, which are affected) This would take some time, but at least addons will not be affected.


> > - Infobar is still dark
> 
> Since this is overlaid on web content (and not part of the normal devtools
> chrome), I think a case could be made for leaving it as dark.  I do see the
> point of using similar colors for consistency though.  There is also a bit
> of a challenge here - the main browser window (on which this is overlaid) is
> not aware of which devtools theme is applied.

I think this is not high priority, but I think it's a good idea to make it light to match the mockup.
Depends on: 967168
(In reply to Tim Nguyen [:ntim] from comment #3)
> (In reply to Brian Grinstead [:bgrins] from comment #2)
> 
> > > - The addon command buttons are inverted
> > 
> > Yes, I've noticed this too.  I suppose we should not invert them, though if
> > the addon author has uploaded a white icon because of the historically
> > dark-only toolbars, it would not be visible.
> > 
> As you can see in the screenshot, the IE, Opera, Chrome icons are inverted,
> that the addon can't actually provide icons for them (it just takes the
> browser icon). Yes, if the author provides a white icon it can be a good
> idea to invert it, but no addon does it. I guess a good solution would be
> extend the toolbox tab functionality adding icon-light as parameter. (Same
> for the command icons, which are affected) This would take some time, but at
> least addons will not be affected.

Fair enough, I have opened Bug 967168 to not invert these icons
(In reply to Tim Nguyen [:ntim] from comment #3)
> (In reply to Brian Grinstead [:bgrins] from comment #2)
> 
> > > - The addon command buttons are inverted
> > 
> > Yes, I've noticed this too.  I suppose we should not invert them, though if
> > the addon author has uploaded a white icon because of the historically
> > dark-only toolbars, it would not be visible.
> > 
> As you can see in the screenshot, the IE, Opera, Chrome icons are inverted,
> that the addon can't actually provide icons for them (it just takes the
> browser icon). Yes, if the author provides a white icon it can be a good
> idea to invert it, but no addon does it. I guess a good solution would be
> extend the toolbox tab functionality adding icon-light as parameter. (Same
> for the command icons, which are affected) This would take some time, but at
> least addons will not be affected.
> 

By the way, what addons are you using that add the the IE, Opera and Chrome command icons?
Flags: needinfo?(ntim007)
(Reporter)

Comment 6

4 years ago
(In reply to Brian Grinstead [:bgrins] from comment #5)
> (In reply to Tim Nguyen [:ntim] from comment #3)
> > (In reply to Brian Grinstead [:bgrins] from comment #2)
> > 
> > > > - The addon command buttons are inverted
> > > 
> > > Yes, I've noticed this too.  I suppose we should not invert them, though if
> > > the addon author has uploaded a white icon because of the historically
> > > dark-only toolbars, it would not be visible.
> > > 
> > As you can see in the screenshot, the IE, Opera, Chrome icons are inverted,
> > that the addon can't actually provide icons for them (it just takes the
> > browser icon). Yes, if the author provides a white icon it can be a good
> > idea to invert it, but no addon does it. I guess a good solution would be
> > extend the toolbox tab functionality adding icon-light as parameter. (Same
> > for the command icons, which are affected) This would take some time, but at
> > least addons will not be affected.
> > 
> 
> By the way, what addons are you using that add the the IE, Opera and Chrome
> command icons?

https://addons.mozilla.org/en-us/firefox/addon/open-with/
Flags: needinfo?(ntim007)
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 7

4 years ago
Oh, btw, the developer toolbar is still dark too.
Depends on: 957117
(Reporter)

Updated

4 years ago
Blocks: 969914
(Reporter)

Updated

4 years ago
No longer blocks: 969914
Depends on: 969914
(Reporter)

Updated

4 years ago
Depends on: 969429, 967634, 967572
(Reporter)

Updated

4 years ago
Depends on: 973191
Depends on: 975124
(Reporter)

Updated

4 years ago
Depends on: 1013557
Whiteboard: meta
(Reporter)

Updated

4 years ago
Depends on: 1013892
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.