Closed Bug 966988 Opened 6 years ago Closed 6 years ago

Debug button stays greyed. Exception: `notify event 'appOpen' threw an exception: TypeError: a is null`

Categories

(DevTools Graveyard :: WebIDE, defect)

x86
All
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 30

People

(Reporter: paul, Assigned: ochameau)

References

Details

(Whiteboard: [needs-coverage])

Attachments

(1 file)

No description provided.
This makes it impossible for me to debug any app I install myself.
I saw this too and reverted to testing backend stuff on b2g using the 'Connect...' menu item.
Does it work if you set devtools.debugger.forbid-certified-apps to false?
It seems to work if I allow certified apps debugging (but I'm having various patch applied on my device...)
Looks like a regression from bug 959420:
http://mxr.mozilla.org/mozilla-central/source/toolkit/devtools/server/actors/webapps.js#569
getManifestFor no longer accepts a second argument but returns a promise instead.
Blocks: 959420
Attachment #8369581 - Flags: review?(paul)
Assignee: nobody → poirot.alex
Ran into this issue while expanding test coverage...  At least we'll be covered for this in the future!
Comment on attachment 8369581 [details] [diff] [review]
Fix getManifestFor regression

We'll need to make sure this lands in 1.4.
Attachment #8369581 - Flags: review?(paul) → review+
Keywords: checkin-needed
Meh, 1.5 will only happen in 6 weeks (I thought it was today).
https://hg.mozilla.org/mozilla-central/rev/7655c489a999
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 30
Keywords: verifyme
Whiteboard: [needs-coverage] → [needs-coverage][qa+]
QA Whiteboard: [qa-]
Keywords: verifyme
Whiteboard: [needs-coverage][qa+] → [needs-coverage]
Product: Firefox → DevTools
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.