sched: Mac Clipboard- Streams for large data sets [PP]

VERIFIED FIXED in M11

Status

()

Core
XUL
P2
enhancement
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: Peter Trudelle, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Trunk
PowerPC
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: NOV-11 have fix, but cannot test. browser edit menu items disabled.)

(Reporter)

Description

19 years ago
Streams for large data sets (test & verify)	0.5 days	sdagley	0%
(Reporter)

Comment 1

19 years ago
Mass changing all XPToolkit M10 feature 'bugs' to target as p2 enhancement for
M10
(Reporter)

Updated

19 years ago
Blocks: 9673

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
Summary: sched: Mac Clipboard- Streams for large data sets → sched: Mac Clipboard- Streams for large data sets [PP]

Updated

19 years ago
Whiteboard: .5 day
(Reporter)

Updated

19 years ago
Blocks: 12669

Updated

19 years ago
Whiteboard: .5 day → feature doesn't work, see comments

Comment 2

19 years ago
tested, verification failed.

Crash in DataStruct::GetData on NS_ADDREFF(*aData) as *aData is NULL.  Actually
the data references several levels up the call chain are NULL so I'm not sure if
this is a problem with transferrable or not.  Rod?  Pink?
(Assignee)

Comment 3

19 years ago
we could be running out of memory if the data is too large. We copy data about 20
times before it is placed on the clipboard. I'm working on fixing that. If that's
not it, then ignore me.

Comment 4

19 years ago
I don't think that's the problem as I'm just testing with a few hundred
characters with LARGE_DATASET_SIZE defined as 10 in nsTransferable.cp.

Updated

19 years ago
Whiteboard: feature doesn't work, see comments → need input from rods, mail has been sent requesting his comments

Comment 5

19 years ago
(I need more info) The only way to know, is to step through this line by until
get there. I assume it is on the paste? Start in the editor code, putting a
break point where they start the paste. It really should be pretty straight
forward. Let me know what you find out, I can help then.

Updated

19 years ago
Whiteboard: need input from rods, mail has been sent requesting his comments → got comments from rods, need to provide more data for him
Target Milestone: M10 → M11

Comment 6

19 years ago
actually the error occurs on a copy.  I'll try and get more data on this for you
next week (9/14) but I'll be working from FL and may not have input on this one
until I return (9/20)
(Assignee)

Comment 7

19 years ago
*** Bug 12508 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 8

19 years ago
in tracking down a bug for eli, i ran into this same problem. I've fixed

transferable so that it doesn't crash anymore when the read from disk fails, but

I haven't looked into why the read from disk is failing in the first place.

FIgured i'd leave that for dagley ;)



steve, repull nsTransferable.cpp if you are looking at this from FL.

Updated

19 years ago
Whiteboard: got comments from rods, need to provide more data for him → 1+ day, got comments from rods, need to provide more data for him

Updated

19 years ago
Assignee: sdagley → pinkerton
Status: ASSIGNED → NEW

Comment 9

19 years ago
the problem turns out to be some unimplemented code in DataStruct::WriteCache

which results in no data to be written to the clipboard file on any platform.

This pinkerton believes is an unfinished remnant of his reworking of the

transferrable code for D&D so reassigning to pink as he's got the best

understanding of what the issues were that blocked completion of the code in the

first place.
(Assignee)

Updated

19 years ago
Whiteboard: 1+ day, got comments from rods, need to provide more data for him → have fix, but cannot test. browser edit menu items disabled.
(Assignee)

Comment 10

19 years ago
i have a fix, but can't do any testing because the edit menu items in browser are
all disabled.
(Assignee)

Comment 11

19 years ago
fix checked in, but cannot test. marking fixed for m11.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 12

19 years ago
Sorry for spam, re-assigning phillip's QA contact XPToolkit/XPWidget bugs to
claudius due to restructure

Updated

19 years ago
Whiteboard: have fix, but cannot test. browser edit menu items disabled. → NOV-11 have fix, but cannot test. browser edit menu items disabled.

Comment 13

19 years ago
so this is still waiting for the edit menu? What up with that? Is there a bug that this can depend
so I/we'll know when Edit is ready?
(Assignee)

Comment 14

19 years ago
it appears you can do the testing in editor with cmd-c and cmd-v. does that help?

Updated

19 years ago
QA Contact: claudius → elig

Comment 15

19 years ago
qa=elig

Updated

19 years ago
Status: RESOLVED → REOPENED

Comment 16

19 years ago
Re-opening using 2000011108 build on Mac OS 8.6.

Specifically, copying a large data set (URL from bug #12541 ---
http://slip/projects/marvin/copy-paste/copy-large-text/shortpage.html) puts
nothing onto the clipboard.

(And, yes, I did do a workaround to avoid bug #14026, of clicking into the URL
field and then into the browser window. The copy took a full 5 seconds, but when
I tried to paste the results into BBEdit, the Clipboard was empty, and the Paste
menu item was disabled.)

Updated

19 years ago
Resolution: FIXED → ---
(Assignee)

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 17

19 years ago
eli, this is already covered in other bugs, notably 21847. This was mostly a

scheduling bug for things that haven't broken.



reresolving fixed.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 18

19 years ago
Sure; I've generalized the title of 21847 so that it more obviously includes
non-table cases. Thanks!
You need to log in before you can comment on or make changes to this bug.