Closed Bug 967009 Opened 8 years ago Closed 3 years ago

Enabling wifi doesn't work in b2g-emulator

Categories

(Firefox OS Graveyard :: Wifi, defect)

x86
Linux
defect
Not set
normal

Tracking

(tracking-b2g:backlog)

RESOLVED WONTFIX
tracking-b2g backlog

People

(Reporter: kats, Unassigned)

References

Details

Local build with "BRANCH=master ./config.sh emulator-jb". When I start it up and try to turn on wifi, the logcat spits out a message "Cannot open /system/etc/wifi/wpa_suplicant.conf: No such file or directory" and the wifi turns back off. Using adb shell I can see in fact there is no /system/etc/wifi folder on the device.

I'm not sure if this is expected to work or not but it would be really nice because it seems like in some situations using the emulator provides a better debugging/reproducing environment than devices.
OS: Mac OS X → Linux
blocking-b2g: --- → backlog
I have found that running the command listed at [1] enabled me to load websites in the B2G browser on the emulator. I'm not sure whether that actually enables wifi or just magically hooks up the Internet in some other way.

[1] https://developer.mozilla.org/en-US/Firefox_OS/Using_the_B2G_emulators#Network_Connectivity
wifi is not supported in emulator yet. If you would like to be able to access internet, set dns server should be a good solution. 

"adb shell setprop net.dns1 10.0.2.3"

There is a bug 991025 try to turn on/off wifi in emulator.
See Also: → 991025
blocking-b2g: backlog → ---
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.