Run Windows 8 unit tests on Date branch

RESOLVED FIXED

Status

Release Engineering
Platform Support
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: jhopkins, Assigned: jhopkins)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Assignee)

Description

4 years ago
Date is already running Talos tests but we also want to run on-change unit tests (as opposed to on-reboot).
(Assignee)

Comment 1

4 years ago
Created attachment 8370101 [details] [diff] [review]
[puppet] add win8_64 platform to BuildSlaves template
Attachment #8370101 - Flags: review?(catlee)
(Assignee)

Comment 2

4 years ago
Created attachment 8370103 [details] [diff] [review]
[buildbot-configs] run Windows 8 unit tests against 64-bit builds
Attachment #8370103 - Flags: review?(catlee)

Updated

4 years ago
Attachment #8370103 - Flags: review?(catlee) → review+

Updated

4 years ago
Attachment #8370101 - Flags: review?(catlee) → review+
(Assignee)

Comment 3

4 years ago
Comment on attachment 8370101 [details] [diff] [review]
[puppet] add win8_64 platform to BuildSlaves template

https://hg.mozilla.org/build/puppet/rev/100aa880d9fd

(note: needs merge to production branch + propagation time to take effect)
Attachment #8370101 - Flags: checked-in+
(Assignee)

Comment 4

4 years ago
puppet change was merged to production and I've verified on one master that it is live.
(Assignee)

Comment 5

4 years ago
Comment on attachment 8370103 [details] [diff] [review]
[buildbot-configs] run Windows 8 unit tests against 64-bit builds

https://hg.mozilla.org/build/buildbot-configs/rev/9031c8e623d6
Attachment #8370103 - Flags: checked-in+

Comment 6

4 years ago
buildbot-config patch is in production :)
(Assignee)

Comment 7

4 years ago
The win8-based tests are failing out right away because Python is not available at the same location on the Windows 8 testers as on the Windows Server 2012 testers.
(Assignee)

Comment 8

4 years ago
Created attachment 8372316 [details] [diff] [review]
[buildbot-configs] override mozharness_python for win8_64
Attachment #8372316 - Flags: review?(catlee)
(Assignee)

Comment 9

4 years ago
Created attachment 8372317 [details] [diff] [review]
[buildbotcustom] allow mozharness_python to be overridden
Attachment #8372317 - Flags: review?(catlee)

Updated

4 years ago
Attachment #8372316 - Flags: review?(catlee) → review+

Updated

4 years ago
Attachment #8372317 - Flags: review?(catlee) → review+
(Assignee)

Comment 10

4 years ago
Comment on attachment 8372316 [details] [diff] [review]
[buildbot-configs] override mozharness_python for win8_64

https://hg.mozilla.org/build/buildbot-configs/rev/941bad7c0fd9
Attachment #8372316 - Flags: checked-in+
(Assignee)

Comment 11

4 years ago
Comment on attachment 8372317 [details] [diff] [review]
[buildbotcustom] allow mozharness_python to be overridden

https://hg.mozilla.org/build/buildbotcustom/rev/9f5db79fe091
Attachment #8372317 - Flags: checked-in+
(Assignee)

Comment 12

4 years ago
I'm going to be on a plane shortly so I will wait until Monday to reconfig buildbot for these patches.
(Assignee)

Comment 13

4 years ago
in production
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.