Closed Bug 967033 Opened 6 years ago Closed 6 years ago

DevTools Themes - Active arrow for side menus is missing on windows

Categories

(DevTools :: General, defect)

All
Windows 8
defect
Not set

Tracking

(firefox29 verified, firefox30 verified)

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 --- verified
firefox30 --- verified

People

(Reporter: bgrins, Assigned: bgrins)

References

Details

Attachments

(4 files, 1 obsolete file)

The jar.mn file needs to be updated, the reference is named itemArrow-ltr.png while it should be itemArrow-ltr.svg
Attached patch windows-sidemenu-arrows.patch (obsolete) — Splinter Review
Try push: https://tbpl.mozilla.org/?tree=Try&rev=cfbcf7225ff8
Assignee: nobody → bgrinstead
Status: NEW → ASSIGNED
Attachment #8369508 - Flags: review?(vporof)
Comment on attachment 8369508 [details] [diff] [review]
windows-sidemenu-arrows.patch

Review of attachment 8369508 [details] [diff] [review]:
-----------------------------------------------------------------

This is why file extensions are the worst idea ever.
Attachment #8369508 - Flags: review?(vporof) → review+
Rebased patch
Attachment #8369508 - Attachment is obsolete: true
Attachment #8369760 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/90a13e41b081
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 30
Blocks: 957117
No longer blocks: 957117
Depends on: 957117
Comment on attachment 8369760 [details] [diff] [review]
windows-sidemenu-arrows.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 957117
User impact if declined: Arrow image in DevTools will not show up in Windows
Testing completed (on m-c, etc.): On m-c since 02-04
Risk to taking this patch (and alternatives if risky): Low risk styling change for DevTools
String or IDL/UUID changes made by this patch:
Attachment #8369760 - Flags: approval-mozilla-aurora?
Attachment #8369760 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Somewhy, this still isn't fixed for me in latest Nightly. I have the latest Nightly, and Windows 8.1 64bit. I'll try to find the source of the problem.
Flags: needinfo?(bgrinstead)
Turns out my Firefox didn't update properly... Still, this should have updated properly.
Flags: needinfo?(bgrinstead)
Keywords: verifyme
I can't reproduce this issue with the Nightly from 2014-02-03 on Win 8 x64: I can see the arrows from the Net, CSS, JS, Security, and Loging menus, both in the web console and browser console.

Could you please give more details in order to reproduce this bug?
Flags: needinfo?(bgrinstead)
One place would be the debugger source list [left side pane] arrow on the selected source label.

Moreover, this is only for Windows Aero.
Flags: needinfo?(bgrinstead)
Attached image sidemenu-arrow.png
(In reply to Manuela Muntean [:Manuela] [QA] from comment #10)
> I can't reproduce this issue with the Nightly from 2014-02-03 on Win 8 x64:
> I can see the arrows from the Net, CSS, JS, Security, and Loging menus, both
> in the web console and browser console.
> 
> Could you please give more details in order to reproduce this bug?

Yes, I see this wasn't very clear.  Basically, this is on Windows aero with the light theme only.  There is a small arrow that shows up next a selected item in a 'side menu widget' (this is used when displaying a list of items, like in the debugger).  You shouldn't see the problem anymore in nightly or aurora - to confirm the bug make sure that the arrow is there.
Attached image Aurora_screenshot.png
With latest Aurora 29.0a2 on Win 8 x64 (with the windows Earth theme selected), I can't see the sidemenu arrow.

Please see the attached screenshot for more details.
(In reply to Manuela Muntean [:Manuela] [QA] from comment #13)
> Created attachment 8386145 [details]
> Aurora_screenshot.png
> 
> With latest Aurora 29.0a2 on Win 8 x64 (with the windows Earth theme
> selected), I can't see the sidemenu arrow.
> 
> Please see the attached screenshot for more details.

Thanks for checking.  I forgot to include the fix for the aero theme after all -- the fix was only for classic Windows theme.  If you check with classic theme the arrow should be there.
I will upload a new patch to fix this issue with the aero theme.
Ah .. the checked in patch is only half the attached patch. I was trying to figure out for minutes now that why I still can't see the arrow on nightly even after the patch looked perfectly fine :)
(In reply to Girish Sharma [:Optimizer] from comment #16)
> Ah .. the checked in patch is only half the attached patch. I was trying to
> figure out for minutes now that why I still can't see the arrow on nightly
> even after the patch looked perfectly fine :)

Yes, I don't know how that happened, but https://bugzilla.mozilla.org/attachment.cgi?id=8369508 is right.  The second one (https://bugzilla.mozilla.org/attachment.cgi?id=8369760) was rebased and must not have included the other part of the patch.
Attachment #8369760 - Flags: checkin+
This is the second part of Attachment 8369508 [details] [diff], which was missing in Attachment 8369760 [details] [diff].

Manuela, an exe for testing on Windows can be grabbed from https://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/bgrinstead@mozilla.com-10020e15b39c/try-win32-debug/firefox-30.0a1.en-US.win32.zip.  Can you please confirm that the arrows are showing up on this build?
Attachment #8386283 - Flags: review+
Flags: needinfo?(manuela.muntean)
I confirm that the arrows are showing up on the build from comment 18, on a Win 8 x64 machine, with both Windows and Earth themes (which are Windows default themes).
Flags: needinfo?(manuela.muntean)
We need to land Attachment 8386283 [details] [diff] (and uplift to Aurora).  I committed only half of the patch that was intended in Comment 4 due to a mistake with rebasing.  I'm happy to make a new bug for this half of the patch if that would make things easier, but marking checkin-needed here since it is all related.
Keywords: checkin-needed
Comment on attachment 8386283 [details] [diff] [review]
windows-sidemenu-arrows-aero.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 957117
User impact if declined: Arrow image in DevTools will not show up in Windows aero theme
Testing completed (on m-c, etc.): On m-c since 03-06, fix confirmed in Comment 19 
Risk to taking this patch (and alternatives if risky): Low risk styling change for DevTools
String or IDL/UUID changes made by this patch:
Attachment #8386283 - Flags: approval-mozilla-aurora?
Attachment #8386283 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified as fixed with latest Nightly & Aurora on Win 8 x86.
Status: RESOLVED → VERIFIED
Keywords: verifyme
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.