Closed Bug 967197 Opened 8 years ago Closed 8 years ago

"Create Account" and "Sign In" links in Sync preferences should go to separate pages

Categories

(Firefox :: Sync, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 + verified
firefox30 --- verified

People

(Reporter: Gavin, Assigned: ttaubert)

References

Details

(Whiteboard: [qa!])

Attachments

(1 file)

Right now both links call gSyncPane.signIn(), which just open about:accounts?action=signin. The "create account" link should go directly to an account creation page rather than the "sign in" page.

This probably depends on the web side/about:accounts supporting an "action" parameter for "createaccount".
Whiteboard: [qa+]
Zack,
  We can have about:accounts handle this case fairly easy, but it will still need to tell the remote iframe to do the right thing.  Who is the best person to help with that, and should that be tracked in a different bug?
Flags: needinfo?(zack.carter)
Duplicate of this bug: 969537
The content-server lets you link directly to the sign in page, e.g. https://accounts.firefox.com/signin, so we could have about:accounts load that page when the action=signin.
Flags: needinfo?(zack.carter)
Assignee: nobody → ttaubert
Status: NEW → ASSIGNED
The attached patch works fine, however we're being redirected to /signup after the server receives our answer to its "session_status" command. Zack, can we not do this for the /signin page?
Flags: needinfo?(zack.carter)
Attachment #8377490 - Flags: review?(mhammond) → review+
https://hg.mozilla.org/integration/fx-team/rev/27959c18c6d2
Whiteboard: [qa+] → [qa+][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/27959c18c6d2
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [qa+][fixed-in-fx-team] → [qa+]
Target Milestone: --- → Firefox 30
(In reply to Tim Taubert [:ttaubert] from comment #6)
> The attached patch works fine, however we're being redirected to /signup
> after the server receives our answer to its "session_status" command. Zack,
> can we not do this for the /signin page?

File a Mozilla Services::Server: Firefox Accounts bug and hang it off bug 969626?
(In reply to Tim Taubert [:ttaubert] from comment #6)
> The attached patch works fine, however we're being redirected to /signup
> after the server receives our answer to its "session_status" command. Zack,
> can we not do this for the /signin page?

I fix for this will be on the staging servers shortly, and pushed to production next week. You can try it out now on the "latest" server: https://accounts-latest.dev.lcip.org.
Flags: needinfo?(zack.carter)
this fix should deploy to prod on 2/25
Comment on attachment 8377490 [details] [diff] [review]
0001-Bug-967197-Create-Account-and-Sign-In-links-in-Sync-.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): FxA sync
User impact if declined: User clicking "Sign in" in sync preferences will be taken to a "create account" page.
Testing completed (on m-c, etc.): Landed on m-c 
Risk to taking this patch (and alternatives if risky): Low
String or IDL/UUID changes made by this patch: None
Attachment #8377490 - Flags: approval-mozilla-aurora?
Attachment #8377490 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Status: RESOLVED → VERIFIED
Whiteboard: [qa+] → [qa!]
You need to log in before you can comment on or make changes to this bug.