Syntax error in "image/src/imgStatusTracker.h" of 24.3.0

RESOLVED DUPLICATE of bug 968461

Status

()

RESOLVED DUPLICATE of bug 968461
5 years ago
5 years ago

People

(Reporter: falk.ziegler, Unassigned)

Tracking

24 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Compilation of the latest esr (24.3.0) release with gcc 4.4.3 fails. Syntax error in "image/src/imgStatusTracker.h at line 215: 
typedef sTObserverArray<mozilla::WeakPtr<imgRequestProxy>> ProxyArray; ?
Should it be: 
typedef nsTObserverArray<mozilla::WeakPtr<imgRequestProxy> > ProxyArray; ?
With the latter change compilation works.
Component: General → ImageLib
Product: Firefox → Core

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 968461
You need to log in before you can comment on or make changes to this bug.