Bug 942164 broke building ESR24 with gcc 4.4

RESOLVED FIXED in Firefox 29

Status

()

Core
ImageLib
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: glandium, Assigned: glandium)

Tracking

24 Branch
mozilla29
x86_64
Linux
Points:
---

Firefox Tracking Flags

(firefox29 fixed, firefox30 wontfix, firefox-esr24 fixed)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
We're still supporting ESR24 building with gcc 4.4, and in that case it doesn't build in C++11 mode, which means >> is not allowed for something other than a shift.
(Assignee)

Updated

4 years ago
Assignee: nobody → mh+mozilla
(Assignee)

Comment 1

4 years ago
Created attachment 8371115 [details] [diff] [review]
Fix imgStatusTracker.h to build with gcc 4.4

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 942164
User impact if declined: Failure to build with gcc 4.4, which is a supported setup for ESR24 (last release to support building with gcc 4.4)
Testing completed (on m-c, etc.): Tested by building 24.3 with the patch applied on debian oldstable
Risk to taking this patch (and alternatives if risky): It's a trivial patch adding a missing space (from C++03 POV).
String or IDL/UUID changes made by this patch: None
Attachment #8371115 - Flags: review?(josh)
Attachment #8371115 - Flags: approval-mozilla-aurora?
Comment on attachment 8371115 [details] [diff] [review]
Fix imgStatusTracker.h to build with gcc 4.4

Did you landed to m-c yet?
Attachment #8371115 - Flags: review+
Attachment #8371115 - Flags: approval-mozilla-aurora?
Attachment #8371115 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 3

4 years ago
We don't support building as C++03 on m-c.
status-firefox29: --- → affected
Attachment #8371115 - Flags: review?(josh) → review+
https://hg.mozilla.org/releases/mozilla-aurora/rev/8607f5696d5e

Do we need this on other branches too?
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-firefox29: affected → fixed
status-firefox30: --- → wontfix
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
(Assignee)

Comment 5

4 years ago
Comment on attachment 8371115 [details] [diff] [review]
Fix imgStatusTracker.h to build with gcc 4.4

Dammit, I meant to request esr24? not aurora? See comment 1.
Attachment #8371115 - Flags: approval-mozilla-aurora+ → approval-mozilla-esr24?
Attachment #8371115 - Flags: approval-mozilla-esr24? → approval-mozilla-esr24+
Duplicate of this bug: 967200
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.