Closed Bug 967333 Opened 6 years ago Closed 6 years ago

Sync does not immediately acknowledge verification even after "Verified" link is opened

Categories

(Firefox for Android :: Android Sync, defect, P1)

Firefox 29
All
Android
defect

Tracking

()

RESOLVED FIXED
Firefox 31
Tracking Status
firefox29 --- wontfix
firefox30 --- fixed
firefox31 --- fixed
fennec 29+ ---

People

(Reporter: liuche, Assigned: nalexander)

References

Details

Attachments

(2 files)

STR:
1. Open Settings > Sync for the first time, create an account.
2. Receive verification email and click on link.
3. See "Verified" page (with non-channel-specific favicon and logo).
4. Open Settings > Sync.

Expected:
Sync is set up

Actual:
Sync checkboxes are greyed out and says the email account needs to be verified. Tapping on the screen sends another confirmation email and displays the "Email sent" screen.
Summary: Sync does not immediately acknowledge verification ever after "Verified" link is opened → Sync does not immediately acknowledge verification even after "Verified" link is opened
This is current expected behavior. We won't know you're verified until the next time we try to sync.

We intend to check more aggressively -- make those screens 'live' -- but that's a balancing act between screwing your phone battery/network/the server, and lagging behind reality.
Component: Firefox Sync: UI → Android Sync
Product: Mozilla Services → Android Background Services
Hardware: ARM → All
Version: unspecified → Firefox 29
Blocks: 963833
Assignee: nobody → nalexander
Status: NEW → ASSIGNED
tracking-fennec: --- → 29+
Priority: -- → P1
Attached file github PR
Following Bug 966104, there's not much to be done here short of polling.  This is strictly best effort; see the commit comment in the PR.
Attachment #8385013 - Flags: review?(rnewman)
Comment on attachment 8385013 [details] [review]
github PR

I worry about this causing races with newly set up clients. If we had more time, I'd be inclined to have a "tentative" syncing mode, where if we're not the first client we only sync if there's data on the server, or we only fetch a token but never actually sync.

File a follow-up, perhaps?
Attachment #8385013 - Flags: review?(rnewman) → review+
This is tracking-fennec29+, but ended up depending on the fixes in Bug 966104, which is tracking-fennec30+.  Requesting uplift to Beta (29) for both.
Attached patch a9dbe97ba404Splinter Review
[Approval Request Comment]
Bug caused by (feature/regressing bug #): initial FxA landing.

User impact if declined: slightly worse initial Sync set-up experience: we won't transition as quickly or smoothly to "your sync is all ready to go" when possible.

Testing completed (on m-c, etc.): tested locally.  This is really small, just asks for a sync on activity start and stop.

Risk to taking this patch (and alternatives if risky): none.

String or IDL/UUID changes made by this patch: none.
Attachment #8404910 - Flags: approval-mozilla-beta?
Attachment #8404910 - Flags: approval-mozilla-aurora?
Attachment #8404910 - Flags: approval-mozilla-beta?
Attachment #8404910 - Flags: approval-mozilla-beta+
Attachment #8404910 - Flags: approval-mozilla-aurora?
Attachment #8404910 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/a9dbe97ba404
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 31
Depends on bug 966104.
Flags: needinfo?(nalexander)
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.