Closed Bug 966104 Opened 6 years ago Closed 6 years ago

Add statusChangeListener to FxA status screen

Categories

(Firefox for Android :: Android Sync, defect, P2)

Firefox 29
All
Android
defect

Tracking

()

RESOLVED FIXED
Firefox 31
Tracking Status
firefox29 --- wontfix
firefox30 --- fixed
firefox31 --- fixed
fennec 30+ ---

People

(Reporter: rnewman, Assigned: nalexander)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [qa+][parallel-30+])

Attachments

(2 files)

http://stackoverflow.com/a/6253713/22003

We'll be told when a sync occurs (which we can show), and we'll know when it finishes (so we can find out what new state we're in).
Blocks: 966105
Blocks: 799726
tracking-fennec: --- → 30+
Priority: -- → P2
Whiteboard: [qa+][parallel-30+]
Attached file github PR
Attachment #8385009 - Flags: review?(rnewman)
Attachment #8385009 - Flags: review?(rnewman) → review+
Blocks: 984509
Depends on: 990680
Duplicate of this bug: 991044
Assignee: nobody → nalexander
Comment on attachment 8385009 [details] [review]
github PR

I reworked the PR quite a bit, so asking for a quick once over.
Attachment #8385009 - Flags: review+ → review?(rnewman)
https://hg.mozilla.org/mozilla-central/rev/06d867c27d14
https://hg.mozilla.org/mozilla-central/rev/8dadefdc975c
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 31
Attachment #8385009 - Flags: review?(rnewman) → review+
Blocks: 967333
This is tracking-fennec30+, but ended up being a pre-req for a tracking-fennec29+ ticket.  Requesting uplift for both.
Attached patch 06d867c27d14Splinter Review
[Approval Request Comment]
Bug caused by (feature/regressing bug #): initial FxA landing.

User impact if declined: "static" Sync Status screen.  In practice, this will manifest itself as greyed-out "What to Sync" boxes immediately after signing-in to Sync.  This will at least get those greyed-out boxes to enable when the first sync complete.

Testing completed (on m-c, etc.): it's been baking for a few days on m-c.

Risk to taking this patch (and alternatives if risky): low.  We're adding new things here.

String or IDL/UUID changes made by this patch: none.

I just checked and this might not apply cleanly on mozilla-beta: there are problems because of my bad landing, but they're easy to work around; but there may be pre-reqs that require work to avoid.  I could go either way: we can cut risk by uplifting to mozilla-aurora, or be a little more aggressive and push to mozilla-beta.
Attachment #8404908 - Flags: approval-mozilla-beta?
Attachment #8404908 - Flags: approval-mozilla-aurora?
Comment on attachment 8404908 [details] [diff] [review]
06d867c27d14

Nick, is it really an issue not to have this feature in 29? The patch is pretty big. Anyway, approving for aurora
By the way, I am not sure why you don't propose a patch for mozilla-beta which applies cleanly?
Attachment #8404908 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(In reply to Sylvestre Ledru [:sylvestre] from comment #9)
> Comment on attachment 8404908 [details] [diff] [review]
> 06d867c27d14
> 
> Nick, is it really an issue not to have this feature in 29? The patch is
> pretty big. Anyway, approving for aurora

Nope, it's not; and I agree with your call.

> By the way, I am not sure why you don't propose a patch for mozilla-beta
> which applies cleanly?

In general, I only ask to uplift things that apply cleanly with |hg graft|.  Because of the amount of FxA uplifts, that's been hard to maintain.  You're correct that it's on me to prepare the patch before asking for uplift.  Next time!
Comment on attachment 8404908 [details] [diff] [review]
06d867c27d14

Removing the beta request since this has non-trivial dependencies and is a little large for this late in the game.
Attachment #8404908 - Flags: approval-mozilla-beta?
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.