Bug 967443 (SQLite3.8.3)

Upgrade to SQLite 3.8.3

RESOLVED FIXED in mozilla30

Status

()

Toolkit
Storage
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: NVD, Assigned: RyanVM)

Tracking

Trunk
mozilla30
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
http://www.sqlite.org/news.html

http://www.sqlite.org/releaselog/3_8_3.html

SQLite version 3.8.3 is a regularly scheduled maintenance release. Upgrading from the previous release is optional.

The most visible change in version 3.8.3 is the addition of support for common table expressions. It is now possible to write a single SELECT statement that will query a tree or graph, using either a depth-first or a breadth-first search. A single SQLite query will even solve Sudoku puzzles or compute the Mandelbrot set. As part of this change, SQLite now accepts a VALUES clause anyplace that a SELECT statement is valid.

This release also includes many small performance enhancements which should give a small speed boost to legacy applications. And there are other minor enhancements such as the addition of the printf() SQL function.
Duplicate of this bug: 967476
Status: UNCONFIRMED → NEW
Ever confirmed: true
Apart from the performance fixes, that are always nice, the WITH clause and the printf function are quite interesting for our use-cases, I think
(Assignee)

Comment 3

4 years ago
Putting SQLite3.8.3 in parentheses in front of the summary doesn't automagically set the alias. You need to explicitly do it.

Try run (on top of m-c rev 1e9f169c9715 for any perf comparisons):
https://tbpl.mozilla.org/?tree=Try&rev=313144981455
Alias: SQLite3.8.3
Summary: (SQLite3.8.3) Upgrade to SQLite 3.8.3 → Upgrade to SQLite 3.8.3
(Assignee)

Comment 4

4 years ago
Created attachment 8371094 [details] [diff] [review]
Upgrade to SQLite 3.8.3 - Mozilla changes
Assignee: nobody → ryanvm
Status: NEW → ASSIGNED
Attachment #8371094 - Flags: review?(mak77)
Comment on attachment 8371094 [details] [diff] [review]
Upgrade to SQLite 3.8.3 - Mozilla changes

Review of attachment 8371094 [details] [diff] [review]:
-----------------------------------------------------------------

I think we'll have fun with common table expressions and printf

Thanks!
Attachment #8371094 - Flags: review?(mak77) → review+
https://hg.mozilla.org/mozilla-central/rev/f33a4a05b6be
https://hg.mozilla.org/mozilla-central/rev/8b72cbfcdbfd
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29

Comment 8

4 years ago
Target Milestone should be mozilla30.
right, someone forgot to update bugzilla to mark mozilla30 as the current nightly
Target Milestone: mozilla29 → mozilla30

Updated

4 years ago
Blocks: 971583
You need to log in before you can comment on or make changes to this bug.