Write mochitests for services/fxaccounts

RESOLVED FIXED in Firefox 31

Status

()

RESOLVED FIXED
5 years ago
11 months ago

People

(Reporter: ferjm, Assigned: jedp)

Tracking

unspecified
Firefox 31
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
In order to avoid regressions like bug 967503 we need to write some mochitests apart from the already existing xpcshell tests.
(Reporter)

Updated

5 years ago
Component: User Story → FxA
Product: Tracking → Firefox
Version: --- → unspecified
Component: FxA → Firefox Sync: Backend
Product: Firefox → Mozilla Services
Assignee: nobody → jparsons
I'm working on this as part of Bug 943521.
Component: Firefox Sync: Backend → FxA
Product: Mozilla Services → Core

Updated

5 years ago
Blocks: 955951
No longer blocks: 941723
Some mochitests will land with Bug 945363 and Bug 963835.

Comment 3

5 years ago
Jed marking this nice to have per Fernando's suggestion in bug 974123 -- place in your list TBD.
Blocks: 974096
No longer blocks: 955951
That's fine.  Mochitests are starting to trickle in with other patches, so we have a start.  But tests should be written for each method.
In addition to those mentioned in Comment 2, more will arrive when we land bug 947374 and bug 971379.

So this is moving forward on other fronts :)
Hi, Fernando,

Over the past few weeks, we've grown a decent bunch of mochitests:

Bug 945363 has mochitests to ensure that RP callbacks fire in the correct sequence

Bug 947374 has mochitests for ensuring that only certified apps can declare a different assertion audience; the tests exercise watch/request for appStatuses 1, 2, and 3.

Bug 971379 has mochitests to ensure that only certified apps can call request() outside of a user event handler; it also has tests for appStatuses 1, 2, and 

Bug 974990 has mochitests for accept-language headers

Bug 978896 adds more mochitests to test how watch() and request() behave when there is or is not already a signed-in user.

I feel like we've got a pretty solid basic coverage with those tests.  Are there others that you think we ought to write?
Flags: needinfo?(ferjmoreno)
(Reporter)

Comment 7

5 years ago
Thanks for adding all these tests Jed! This looks like a nice battery of tests, specially for the RP API.

It would also be great to have some marionette functional tests for B2G, do you know if there is any bug tracking this work?
Flags: needinfo?(ferjmoreno)

Comment 8

5 years ago
Fernando this is bug 989368 .

Comment 9

5 years ago
I will mark this Resolved/Fixed unless one of you feels otherwise. bug 989368 is a project dependency and should not get lose.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla31

Updated

11 months ago
Product: Core → Firefox
Target Milestone: mozilla31 → Firefox 31
You need to log in before you can comment on or make changes to this bug.