Closed Bug 967553 Opened 6 years ago Closed 6 years ago

crash in throwSqliteException

Categories

(Firefox for Android :: General, defect, critical)

29 Branch
ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Firefox 30
Tracking Status
firefox29 + fixed
firefox30 --- fixed

People

(Reporter: aaronmt, Assigned: jchen)

References

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-65315147-df79-4aa3-a1d2-ea9d32140203.
=============================================================
Looks like bug 964859 didn't fix the real issue. The real problem is a regression from bug 801571.
Assignee: nobody → nchen
Blocks: 801571
Status: NEW → ASSIGNED
Keywords: regression
Comment on attachment 8370149 [details] [diff] [review]
Restore to using __wrap_free

Changing back to free() will give us back our wrapped free().
Attachment #8370149 - Attachment description: Bug 967553 - Restore to using __wrap_free; r= → Restore to using __wrap_free
Attachment #8370149 - Flags: review?(gpascutto)
Comment on attachment 8370149 [details] [diff] [review]
Restore to using __wrap_free

Review of attachment 8370149 [details] [diff] [review]:
-----------------------------------------------------------------

Well at least that made things simpler on our side.
Attachment #8370149 - Flags: review?(gpascutto) → review+
https://hg.mozilla.org/mozilla-central/rev/c0a437581b9b
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 30
See Also: → 959254
Comment on attachment 8370149 [details] [diff] [review]
Restore to using __wrap_free

[Approval Request Comment]

Bug caused by (feature/regressing bug #): Bug 801571

User impact if declined: Crashes

Testing completed (on m-c, etc.): Locally, m-c

Risk to taking this patch (and alternatives if risky): Very small; patch just fixes crash

String or IDL/UUID changes made by this patch: None
Attachment #8370149 - Flags: approval-mozilla-aurora?
Attachment #8370149 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.