SELECT element inside of DIV with "overflow:auto" does not drop when you click on it.

RESOLVED DUPLICATE of bug 115253

Status

()

P2
normal
RESOLVED DUPLICATE of bug 115253
17 years ago
16 years ago

People

(Reporter: nicks, Assigned: rods)

Tracking

({testcase})

Trunk
Future
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
build 20010820
1. Browse the following HTML page:
<html>
<body>
<br>
<br>
<div style="overflow:auto;height:400;">
<select>
<option>Option 1</option>
<option>Option 2</option>
</select>
</div>
</body>
</html>
2. Click on the <select> element
Result:
It doesn't actually drop down.

In "nsListControlFrame::MouseDown", "IsClickingInCombobox" is returning false.

Comment 1

17 years ago
Created attachment 47036 [details]
Testcase

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
OS: Windows 2000 → All

Comment 2

17 years ago
You can see this at http://www.expofusion.com while it's still in demo mode.
Use the default logon, and then go to http://www.expofusion.com/msgsys/session.jsp
(Reporter)

Comment 3

17 years ago
A workaround for this bug is to add "position:relative;" to the style attribute 
of the <div>.
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.2

Comment 4

17 years ago
PLEASE change this milestone to 1.0, this breaks our site.
I imagine this construct must be on more than a handful of sites besides ours.
I thought regressions had a high priority?

BTW, the link I provided earlier now uses TBODY's overflow style to scroll.
We'd use it everywhere if !@#$ IE didn't blow up on it.
(Assignee)

Updated

17 years ago
Priority: -- → P2
Target Milestone: mozilla1.2 → Future

Comment 5

17 years ago
*** Bug 129722 has been marked as a duplicate of this bug. ***

Comment 6

17 years ago
This bug is nasty, but at least the "position:relative" helps as workaround.
Should realy make it into 1.0 !

Updated

17 years ago
QA Contact: madhur → tpreston
*** Bug 147457 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
I just found this bug last night, took 3 hours to track it down the overflow
element. Very nasty bug, and I'm seeing the overflow used more and more. Any
time estimate on when we can expect a fix?
*** Bug 158833 has been marked as a duplicate of this bug. ***
*** Bug 161101 has been marked as a duplicate of this bug. ***

Comment 11

16 years ago
The "position:relative" does not help at all.

In all pages I have a DIV with overflow:auto I tried to add "position:relative"
on the style parameter of the DIV element but it does not work.
I am using Mozilla 1.0 (Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.0)
Gecko/20020530)
The only workaround that worked was:
If the DIV is inside other DIV, a TABLE or a combination of both, I took out it
from that elements and place it at almos top-level of HTML document, before the
</body> tag and add "position:absolute; top: y; left: x" where x and y are the
horiz. and vert. position in the current frame. 
Example:

<html>
...
...
<body>
<div ...>
<table>
<tr><td><!-- The div with a select element was here previously --></td></tr>
</table>
</div>

<!-- Now the DIV is here, out from TABLE or DIV and it WORKS -->
<!-- I set its position with top and left -->
<div style="position:absolute; top: 100; left: 40;" id="gridDOC">
<!--  Inside DIV here -->
</div>

</body>
</html>

Comment 12

16 years ago
Partially WFM in Mozilla 1.1 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1) Gecko/20020826

I have no trouble clicking the dropdown list for the first time. Sometimes, not
always, after selecting an option, I have to click elsewhere on the document
before I can select another option (i.e. have the list drop down again).

Another supposed testcase,
http://members.iinet.net.au/~xions/dev/test/mozillaform.html WFM all the time.

Comment 13

16 years ago
This bug needs to be resolved still.

A select box inside a div style=overflow:auto still does not work.  This bug's 
last activity was last year.

Comment 14

16 years ago
Testcase WFM with Mozilla 1.3, Windows 2000.
This was bug 115253, and has been fixed for over six months now.

*** This bug has been marked as a duplicate of 115253 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.