Closed Bug 967674 Opened 6 years ago Closed 6 years ago

Port new Fxa sync options work to in-content prefs

Categories

(Firefox :: Sync, defect)

29 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 31
Tracking Status
firefox29 + verified
firefox30 + verified
firefox31 --- verified

People

(Reporter: ntim, Assigned: Paenglab)

References

Details

(Whiteboard: [mentor=mak] [mentor=markh] p=0 s=it-31c-30a-29b.2 )

Attachments

(1 file)

When I finish setting up my Firefox account then go to about:accounts, it provides me a "Manage" link, that link makes me go to the options. In the options, there is a link called "Set up Firefox Sync" that makes me go to "about:accounts". So basically, setting up Firefox sync makes me go back and forth those pages. There's also a reconnect to sync button in the menu panel even if I finished setting up my FFX account.

I'll try restarting Firefox, see if this still happens.
Blocks: 905997
Still happens after restart
Do you use in-content prefs ?
(In reply to Guillaume C. [:ge3k0s] from comment #2)
> Do you use in-content prefs ?

Yep
Doesn't happen with in content prefs disabled.
So yeah I encountered the same issue. It's because the Sync pane hasn't been ported to in-content prefs yet.
Summary: New Firefox sync just makes me back and forth about:accounts and the settings → New Firefox sync just makes me go back and forth about:accounts and the settings
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: New Firefox sync just makes me go back and forth about:accounts and the settings → Port new Fxa sync options work to in-content prefs
Component: General → FxA
Duplicate of this bug: 980255
Whiteboard: [mentor=mak]
Duplicate of this bug: 984925
Whiteboard: [mentor=mak] → [mentor=mak] [mentor=markh]
Since bug 738796 is gonna land soon. I think this bug should have an highest priority.
(In reply to Guillaume C. [:ge3k0s] from comment #8)
> Since bug 738796 is gonna land soon. I think this bug should have an highest
> priority.

That bug won't make in-content prefs the default yet.
(In reply to :Gijs Kruitbosch (no internet 29 Mar - 6 Apr) from comment #9)
> (In reply to Guillaume C. [:ge3k0s] from comment #8)
> > Since bug 738796 is gonna land soon. I think this bug should have an highest
> > priority.
> 
> That bug won't make in-content prefs the default yet.

I know there is still a bunch of priority to land in-content prefs, but in fact this bug is one of them. ;)
This patch updates the inContent synch files to the actual prefWindow files.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8398915 - Flags: review?(mhammond)
Comment on attachment 8398915 [details] [diff] [review]
inContentNewSynch.patch

Review of attachment 8398915 [details] [diff] [review]:
-----------------------------------------------------------------

looks good, thanks.
Attachment #8398915 - Flags: review?(mhammond) → review+
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/91494766ce39
Keywords: checkin-needed
Whiteboard: [mentor=mak] [mentor=markh] → [mentor=mak] [mentor=markh][fixed-in-fx-team]
Duplicate of this bug: 989287
Whiteboard: [mentor=mak] [mentor=markh][fixed-in-fx-team] → [mentor=mak] [mentor=markh][fixed-in-fx-team] p=0
Whiteboard: [mentor=mak] [mentor=markh][fixed-in-fx-team] p=0 → [mentor=mak] [mentor=markh][fixed-in-fx-team] p=2
https://hg.mozilla.org/mozilla-central/rev/91494766ce39
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [mentor=mak] [mentor=markh][fixed-in-fx-team] p=2 → [mentor=mak] [mentor=markh] p=2
Target Milestone: --- → Firefox 31
Whiteboard: [mentor=mak] [mentor=markh] p=2 → [mentor=mak] [mentor=markh] p=0 s=it-31c-30a-29b.2
Tracy, are you the right person to verify for Sync issues or do you want to pass this on to Florin and  his team?  Thanks!
Flags: needinfo?(twalker)
Whiteboard: [mentor=mak] [mentor=markh] p=0 s=it-31c-30a-29b.2 → [mentor=mak] [mentor=markh] p=0 s=it-31c-30a-29b.2 [qa+]
No longer blocks: fxdesktopbacklog
Flags: firefox-backlog+
lizzard,  yes, assign me as QA contact for any client side Sync bugs. Thanks.


verified this one is fixed on 31.  It will need uplift to 29 and 30.
Flags: needinfo?(twalker)
QA Contact: twalker
(In reply to [:tracy] Tracy Walker - QA Mentor from comment #17)
> It will need uplift to 29 and 30.

Indeed. Richard or Mark, can either of you make the required uplift requests if you're comfortable with the patch going to 29/30 ? Thanks!
Flags: needinfo?(richard.marti)
Flags: needinfo?(mhammond)
Comment on attachment 8398915 [details] [diff] [review]
inContentNewSynch.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): FxA sync
User impact if declined: In-content prefs will not support FxA sync
Testing completed (on m-c, etc.): On m-c
Risk to taking this patch (and alternatives if risky): Low
String or IDL/UUID changes made by this patch: None
Attachment #8398915 - Flags: approval-mozilla-beta?
Attachment #8398915 - Flags: approval-mozilla-aurora?
Flags: needinfo?(richard.marti)
Flags: needinfo?(mhammond)
Attachment #8398915 - Flags: approval-mozilla-beta?
Attachment #8398915 - Flags: approval-mozilla-beta+
Attachment #8398915 - Flags: approval-mozilla-aurora?
Attachment #8398915 - Flags: approval-mozilla-aurora+
Hi Tracy, will verification of this bug be able to be completed before the end of our iteration on Monday April 14?
Flags: needinfo?(twalker)
Marco, this has already been verified on Nightly (Fx31).  Also, I'll be on the lookout for the uplifts to  verify on each branch as the landings occur. With next available build, that is. :-)
Flags: needinfo?(twalker)
Status: RESOLVED → VERIFIED
QA Whiteboard: [qa!]
Whiteboard: [mentor=mak] [mentor=markh] p=0 s=it-31c-30a-29b.2 [qa+] → [mentor=mak] [mentor=markh] p=0 s=it-31c-30a-29b.2
You need to log in before you can comment on or make changes to this bug.