Setup flow doesn't offer reset/merge options

RESOLVED FIXED

Status

()

RESOLVED FIXED
5 years ago
a year ago

People

(Reporter: rnewman, Unassigned)

Tracking

(Blocks: 1 bug, {productwanted, uiwanted, user-doc-needed})

Firefox 29
All
Android
productwanted, uiwanted, user-doc-needed
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Comment hidden (empty)
(Reporter)

Updated

5 years ago
Duplicate of this bug: 709361
(Reporter)

Comment 2

5 years ago
Also needs desktop-side. Not related to Reset Sync (the operation).

productwanted to consider how urgent this is. (Happy to talk about this.)

uiwanted to figure out how to surface this during setup.

user-doc-needed to document what's going on for users who don't get what they need from SUMO.
Keywords: productwanted, uiwanted, user-doc-needed
(Reporter)

Updated

5 years ago
Flags: needinfo?(deb)
This isn't needed for MVP/v1, to be sure.  Sorting out urgency is something that will have to be discussed with a larger group - mmayo, chad, ibarlow, rfeeley, jgruen, madhava & myself, likely.

Is there a list of v2+ features/user stories being compiled anywhere?  This should likely be added to that so it's part of the product planning when we get to that stage.
Flags: needinfo?(deb)
(Reporter)

Comment 4

5 years ago
(In reply to Deb Richardson [:dria] from comment #3)

> Is there a list of v2+ features/user stories being compiled anywhere?  This
> should likely be added to that so it's part of the product planning when we
> get to that stage.

https://id.etherpad.mozilla.org/sync-post-29-ux-follow-up?
(Reporter)

Comment 5

5 years ago
And if that's not it, might as well start something somewhere.
We didn't see this feature offered in other browsers, and don't believe it's a feature that is conventionally used in other syncing solutions (like contacts). Because the cognitive load is so high, and the operations are so potentially destructive, we did not include it in the current Sync. I will confirm with John Gruen, but assume we're aligned on this unless you hear more.
(Reporter)

Comment 7

5 years ago
On the other hand: we *know* that Firefox Sync needs a lot of help getting to a stable working state, so omitting this leave us saying to users "sorry, please switch to Chrome".

Comment 8

5 years ago
Yeah I'm with Ryan on this one. I don't think there's a good UX solution to sorting big wads of data, and that this is probably better addressed in the Sync protocol itself. That having been said, I'm not entirely clear on the use cases you're referring to Richard. Maybe you can provide a specific example of the problem.
(Reporter)

Comment 9

5 years ago
I would *love* for this to be fixed by a new, properly designed, robust, device-centric syncing protocol.

Realistically I can't expect that that will ship this year, let alone in the next release.

I'd also love for this -- as with other apps' syncing solutions -- to be fixed via:

* An actual device management portal, where you could unlink, wipe, etc. your attached devices.
* A canonical front-end to your "cloud" data, where things you fix would reliably overrule local changes.
* A server-authoritative data model.

But we don't have any of those. The only mechanism that the Sync protocol exposes for device management is its command channel, with resetting concepts layered on top.

Other solutions typically offer one of the above, or they offer 'interactive' syncing ("this sync will change more than 5% of your contacts…"). We can't really do that, either.


The use cases for which Reset Sync is necessary:

* Sync has just corrupted my bookmarks. (This is a spectacularly common occurrence.) I want to restore them from a backup, or fix them myself (e.g., manually deleting duplicates), and then make sure that all of my other devices have the same set.

* My local bookmarks database has been corrupted, and my sync isn't working. (This is also a common occurrence.) I want to wipe my local device and replace its contents with the server's data. I try deleting places.sqlite, like the forums told me, but no matter how often I click Sync Now, bookmarks from my other computer aren't appearing on my laptop.

* I've been using Sync for a while, and I've noticed that my devices seem to have diverged: stuff I've deleted on one hasn't been deleted on another, bookmarks are in the wrong place, etc. I want to fix this somehow.

* I used Clear Private Data on one of my devices, but my porn^WChristmas gift buying history is on my work machine, and presumably also on my Sync server! How do I make it go away? I already deleted it on my computer, but as soon as I set up Sync on my phone it comes back from the dead! Sync is rubbish.



I really see only three options here:

* We insert some kind of management into the UI we ship.

* We add Reset Sync to the setup process, and force users in the above situation to sign out of FxA and sign back in in order to do a reset.

* We spend the engineering cycles to build a "Sync Maintenance" add-on with a shitty programmer UI, and link to that add-on from all over SUMO.
Richard, a user who is not familiar with the inner workings of Sync is going to assume that when syncing is active, that syncing is active and continuous. If their local bookmarks become messed up, the assumption is that, because syncing happens continually, they are messed up on the server too. i don't image that unless we offer a more advanced, dated rollback feature, that a user would use Sync as a backup service.

We definitely want to expose more features on the server side, perhaps even allowing users to view bookmarks on the web, and delete types like history, passwords, but I'm not sure your view of Sync as recovery is how the uninitiated imagine it.
(Reporter)

Comment 11

5 years ago
On a slightly different note: I just realized that this bug isn't about Reset Sync, it's about directionality during setup.

What are your thoughts on that?

The situation: I want to set up this Firefox to be just like what's on my other devices, and I don't care about what's on this thing already. (And the mirror of that.)


Re Reset Sync:

I have no expectation that users will go looking for something called Reset Sync. We know from experience that users do discover and use it to try to self-help, and it's extensively used for support.

By not exposing it in the UI we're making it much more difficult for users to fix their experience with our most broken piece of software.


> i don't image that unless we offer a more advanced, 
> dated rollback feature, that a user would use Sync
> as a backup service.

We know that users do indeed use Sync as a backup service, but when I say "restore", I mean from the bookmark system's own backup process, which is automatic and well-documented on SUMO.

Restoring from bookmarks will not work correctly in combination with Sync. I doubt restoring from Xmarks will work either. Many bulk operations will also break (Bug 978339, for example). 


Let me be clear: I'm not suggesting that Reset Sync is an awesome feature, is the best solution for many problems, is something that users just love using, or anything like that. I would love for Sync (and Firefox's data stores) to just work, and for user actions like bookmark restorations, Xmarks, et al to behave correctly.

Sync is a broken, unreliable, and badly designed system, and Reset Sync is one of the only shovels we provide users to dig themselves out of the holes they fall into.


If we don't provide it on desktop, SUMO will have to start telling people how to modify Sync's internal behavior prefs to achieve the same result. If we don't provide it on Android, users will be unable to self-serve at all in a number of bug situations.

I've already fielded a bunch of IRC 'help!'s from users who were unable to fix their problem because Reset Sync is gone in 29. That doesn't encourage me.

Comment 12

a year ago
Update from the future: at least we have a "do you want to merge stuff? yes: sign in, no: don't sign-in" prompt now.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED

Updated

a year ago
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.