panels - visual/copy bugs

RESOLVED DUPLICATE of bug 949051

Status

Firefox OS
Gaia
RESOLVED DUPLICATE of bug 949051
4 years ago
4 years ago

People

(Reporter: _6a68, Assigned: _6a68)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

4 years ago
as with 967821, tracking the micro-fixes here, rather than waste two hours filing micro-bugs

* logged-in panel
  * remove hyphenation if possible (todo: will this hurt langs with long words?)
  * wrap email in <strong> tags, not <em>s
  * capitalize "My" in the paragraph
  * insert marketplace icon (have to copy it over from external-apps)
* logged-out panel
  * button should be blue inviting button, not grey button
  * names of apps in description text paragraph should be <strong>
  * capitalize 'My' in paragraph
(Assignee)

Updated

4 years ago
Assignee: nobody → 6a68
Blocks: 967622
(Assignee)

Comment 1

4 years ago
need to figure out how to style phrases inside the paragraph, moving that bit ("names of apps in description text paragraph should be <strong>") to the l10n bug, 967787
(Assignee)

Comment 2

4 years ago
i am not going to disable hyphenation. in langs like german, this will cause insane issues where text overflows the container.
(Assignee)

Comment 3

4 years ago
ah, also going to move the marketplace icon addition into the wmf icon bug--i'm a bit concerned we won't get the wmf icon in time to land it for 1.4, so not including either makes it passable if necessary.

Recapping, the actual list of changes covered by this bug:

* logged-in panel
  * wrap email in <strong> tags, not <em>s
  * capitalize "My" in the paragraph
* logged-out panel
  * button should be blue inviting button, not grey button
  * names of apps in description text paragraph should be <strong>
  * capitalize 'My' in paragraph
(Assignee)

Comment 4

4 years ago
fix pushed to settings-app-WIP branch:

https://github.com/6a68/gaia/commit/1c9289d

will be added into gigantic settings app PR:

https://github.com/mozilla-b2g/gaia/pull/15692
(Assignee)

Comment 5

4 years ago
As ferjm pointed out[1], stuff fixed as part of a larger patch should be closed as a dup of that patch.

So, closing as dup of 949051

[1] https://bugzilla.mozilla.org/show_bug.cgi?id=941723#c5
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 949051
You need to log in before you can comment on or make changes to this bug.