The titlebar is rendered when Firefox is in fullscreen mode and unfocused

RESOLVED DUPLICATE of bug 1064787

Status

()

defect
RESOLVED DUPLICATE of bug 1064787
5 years ago
4 years ago

People

(Reporter: johan.charlez, Unassigned)

Tracking

25 Branch
All
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
STR:
  1. Toggle fullscreen mode for a tab or html5 video.
  2. Unfocus Firefox (e.g. by alt-tabbing).

Expected:
  Titlebar shouldn't render.

Actual:
  Titlebar is visible.

Note:
  I have the Aero theme enabled and the title bar renders with the Windows Classic theme.
(Reporter)

Updated

5 years ago
Component: General → XP Toolkit/Widgets: XUL
Product: Firefox → Core
(Reporter)

Comment 1

5 years ago
Posted image screenshot
Added a screenshot with 3 examples.

In the first example, only 1px of the titlebar is rendered.
(Reporter)

Updated

5 years ago
Component: XP Toolkit/Widgets: XUL → Widget: Win32
(Reporter)

Comment 2

5 years ago
Is this bug in the correct component?

Can I provide more information to help fix this bug?
(Reporter)

Updated

5 years ago
Blocks: 453063, 545812
Issue reported again in bug 1109224, for Firefox 35. 

Simple steps to reproduce (tried on Win 7 x64 with Firefox 35 Beta 8):
1. Open Firefox.
2. Toggle fullscreen (F11).
3. <Ctrl>+<T> to open a new tab.
4. Click inside the new tab page and wait for the top bar to disappear.
5. Press the <windows> key on the keyboard. 

Result: the windows start menu opens, and behind it Firefox displays with a Classic Theme titlebar overlayed on top of the page (see https://bug1109224.bugzilla.mozilla.org/attachment.cgi?id=8533859). If it doesn't reproduce on the first attempt, just try steps 4 & 5 once more.
Duplicate of this bug: 1109224
(Reporter)

Comment 5

4 years ago
It's possible to reproduce this bug in the browser's fullscreen mode (F11), HTML5 video and the  fullscreen API.

Because of this I believe it boils down to a bug in the implementation of fullscreen mode for Windows (bug 68136), please correct me if I'm wrong though. Marking as blocking bug 68136 for this reason.
Blocks: 68136
(Reporter)

Updated

4 years ago
Duplicate of this bug: 876464
(Reporter)

Comment 7

4 years ago
I can only find reports on this issue from users running win 7, so this should probably block bug 474052.
Blocks: win7support
Summary: The title bar is rendered when Firefox is in fullscreen mode and unfocused → The titlebar is rendered when Firefox is in fullscreen mode and unfocused
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1064787
You need to log in before you can comment on or make changes to this bug.