[GTK Themes] Gtk-WARNINGs on startup[PP]

VERIFIED DUPLICATE of bug 10650

Status

()

Core
XUL
P4
enhancement
VERIFIED DUPLICATE of bug 10650
19 years ago
18 years ago

People

(Reporter: dbaron, Assigned: Stuart Parmenter)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Whenever I start viewer or apprunner I see (well, different sequence for viewer,
but same four warnings):

david@dell ~/mozilla/package > ./mozilla-apprunner.sh
MOZILLA_FIVE_HOME=/home/david/mozilla/package
  LD_LIBRARY_PATH=/home/david/mozilla/package
      MOZ_PROGRAM=./apprunner
        moz_debug=0
     moz_debugger=

Gtk-WARNING **: /usr/lib/gtk/themes/engines/libmetal.so: undefined symbol:
gtk_range_draw_trough

Gtk-WARNING **: /usr/lib/gtk/themes/engines/libmetal.so: undefined symbol:
gtk_range_draw_trough

Gtk-WARNING **: /usr/lib/gtk/themes/engines/libmetal.so: undefined symbol:
gtk_range_draw_trough

Gtk-WARNING **: /usr/lib/gtk/themes/engines/libmetal.so: undefined symbol:
gtk_range_draw_trough
Reading file...
Reading file...Done


I'm using gtk+ 1.2.1, which is what comes with RedHat 6.0.

Updated

19 years ago
Assignee: trudelle → pavlov
Priority: P3 → P4
Target Milestone: M15

Comment 1

19 years ago
I don't like warnings either, but since no bad behavior is ascribed
to this, reassigning to pavlov as p4 for m15
(Assignee)

Updated

19 years ago
Severity: normal → enhancement
Status: NEW → ASSIGNED
Summary: Gtk-WARNINGs on startup → [GTK Themes] Gtk-WARNINGs on startup
(Assignee)

Comment 2

19 years ago
moving theme bugs to M15

Updated

19 years ago
Summary: [GTK Themes] Gtk-WARNINGs on startup → [GTK Themes] Gtk-WARNINGs on startup[PP]

Comment 3

19 years ago
*** Bug 9727 has been marked as a duplicate of this bug. ***

Comment 4

19 years ago
*** Bug 9727 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 5

19 years ago
this is due to the version of gtk linked against mozilla being different from
the one you have installed on your system.  marking as a duplicate of bug 10650

*** This bug has been marked as a duplicate of 10650 ***
(Reporter)

Comment 6

19 years ago
Eh?  I see these warnings on the ones I build myself too.  (e.g., CVS pull on
Sat Aug 28, 12:15PDT, which is my current one).
(Assignee)

Comment 7

19 years ago
have you tried building the themes yourself?
(Reporter)

Comment 8

19 years ago
No.  Is it a problem with my build of GTK (the default in RH 6.0) that has
nothing to do with Mozilla at all?
(Assignee)

Comment 9

19 years ago
thats my thinking...
(Reporter)

Comment 10

18 years ago
For the record, these went away when I upgraded to gnome 1.0.53.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 11

18 years ago
verified duplicate of 10650 (could be invalid I guess).  Inertia wins.  10650
can be the 'link dynamically' bug.
You need to log in before you can comment on or make changes to this bug.