Add feedback item in Settings charm

VERIFIED FIXED in Firefox 28

Status

defect
P1
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: sfoster, Assigned: sfoster)

Tracking

unspecified
Firefox 30
x86_64
Windows 8.1
Dependency tree / graph

Firefox Tracking Flags

(firefox27 unaffected, firefox28 verified, firefox29 verified, firefox30 verified, b2g-v1.3 fixed)

Details

(Whiteboard: p=2 s=it-30c-29a-28b.1 r=ff30)

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

5 years ago
As an interim measure, in order to allow easy metro-specific feedback in early releases we need a new "feedback" item in the Settings charm menu. While the default bookmark (Bug 963688) is ephemeral, this will always be there. When the new feedback UI arrives (Bug 963691) the menu item can be co-opted to show that instead of going direct to input.mozilla.org
(Assignee)

Comment 1

5 years ago
In order to avoid adding new strings and allow this to make its way to aurora and beta, we may be able to use http://dxr.mozilla.org/mozilla-central/source/browser/locales/en-US/chrome/browser/baseMenuOverlay.dtd#35
(Assignee)

Updated

5 years ago
Assignee: nobody → sfoster
Blocks: 963688
Status: NEW → ASSIGNED
Priority: -- → P1
QA Contact: jbecerra
Whiteboard: [release28] p=0 s=it-30c-29a-28b.1
Target Milestone: --- → Firefox 28
Hey Sam, can you add a point value.
Flags: needinfo?(sfoster)
(Assignee)

Comment 3

5 years ago
Probably a 2, hopefully a 1
Flags: needinfo?(sfoster)
Whiteboard: [release28] p=0 s=it-30c-29a-28b.1 → [release28] p=2 s=it-30c-29a-28b.1
Comment on attachment 8371974 [details] [diff] [review]
Add feedback item to settings charm, using string from baseMenuOverlay.dtd

Review of attachment 8371974 [details] [diff] [review]:
-----------------------------------------------------------------

Awesomely hacky!  :)

r=mbrubeck as long as this all gets backed out when we add our own feedback UI.

::: browser/metro/locales/jar.mn
@@ +38,5 @@
>  
>  @AB_CD@.jar:
>  relativesrcdir browser/locales:
>    locale/browser/syncBrand.dtd            (%chrome/browser/syncBrand.dtd)
> +  locale/browser/baseMenuOverlay.dtd      (%chrome/browser/baseMenuOverlay.dtd)

Should probably add a comment that this is temporary hack, since we don't want to add dependencies on these browser strings in the long term.
Attachment #8371974 - Flags: review?(mbrubeck) → review+
(Assignee)

Comment 6

5 years ago
Added comment per review, carrying r+
Attachment #8371974 - Attachment is obsolete: true
Attachment #8372378 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/010e1b10e1fe
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: Firefox 28 → Firefox 30
Whiteboard: [release28] p=2 s=it-30c-29a-28b.1 → p=2 s=it-30c-29a-28b.1 r=ff30
Blocks: metrobacklog
No longer blocks: metrov1backlog
Went through the following new addition and made sure everything was working, used the following Nightly build:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-02-12-03-02-01-mozilla-central/

- Ensured that "Submit Feedback..." appeared under the "Settings" charm without any issues
- Ensured that taping on "Submit Feedback..." slides in the Navigation App Bar and opens a new tab
- Ensured that the correct website is being opened once "Submit Feedback..." is taped under the "Settings" charm
- Ensured that "Submit Feedback..." works correctly under several other combinations of snapped view
- Ensured that the new item was placed in an intuitive order (e.g. not at the top, or underneath Options)
- Ensured that all the other flyouts under the "Settings" charm are working correctly
Status: RESOLVED → VERIFIED
(Assignee)

Comment 10

5 years ago
Comment on attachment 8372378 [details] [diff] [review]
Add feedback item to settings charm, using string from baseMenuOverlay.dtd

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Interim workaround for 963691
User impact if declined: No means to submit feedback without manually typing in to the url bar
Testing completed (on m-c, etc.): tested
Risk to taking this patch (and alternatives if risky): low risk, metro-only patch
String or IDL/UUID changes made by this patch: none
Attachment #8372378 - Flags: approval-mozilla-aurora?
Attachment #8372378 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Updated

5 years ago
Blocks: 972608
Went through the following verification process with the latest Nightly and Aurora builds:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-02-18-03-02-02-mozilla-central/
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-02-18-00-40-01-mozilla-aurora/

- Went through the test cases that have been added in comment #9 without any issues
- Ensured that the "Feedback" website is being placed in the correct order under the Navigation App Bar

Updated

5 years ago
Flags: needinfo?(jmathies)

Updated

5 years ago
Flags: needinfo?(jmathies)
(Assignee)

Comment 13

5 years ago
Comment on attachment 8372378 [details] [diff] [review]
Add feedback item to settings charm, using string from baseMenuOverlay.dtd

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Interim workaround for 963691
User impact if declined: No means to submit feedback without manually typing in to the url bar
Testing completed (on m-c, etc.): tested
Risk to taking this patch (and alternatives if risky): low risk, metro-only patch
String or IDL/UUID changes made by this patch:
Attachment #8372378 - Flags: approval-mozilla-beta?
Attachment #8372378 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Changing this back to "Resolved" and will complete the verification process once this lands in BETA and is tested using the test cases from comment #9
Status: VERIFIED → RESOLVED
Last Resolved: 5 years ago5 years ago
Kamil, based on comment 14 this should be fixed in Firefox 28.0b7 which should be available Friday morning for you.
Flags: needinfo?(kamiljoz)
Keywords: verifyme
QA Contact: jbecerra → kamiljoz
Went through the verification process using the following build:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/28.0b7/win32/en-US/

- Went through all the test cases from comment #9
- Went through the extra test cases from comment #12
- Went through the above test cases using both the X1 Carbon and the Surface Pro 2
Status: RESOLVED → VERIFIED
Flags: needinfo?(kamiljoz)
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.