Closed Bug 969535 Opened 6 years ago Closed 6 years ago

Add tests for search providers

Categories

(Firefox for Android :: Testing, defect)

All
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 997485

People

(Reporter: mcomella, Unassigned)

References

Details

(Whiteboard: [mentor=mcomella][lang=java])

Search provider searches have regressed multiple times in the past (e.g. bug 898975,
bug 969015), typically because we rely on an external entity to maintain a persistent search scheme. We should add some tests, and note that they do not need to be robocop tests (and perhaps are better as not-robocop tests).
This will probably need extension of AboutHomeComponent to support entering a URL and clicking on one of the associated search providers.

The search provider to select should probably be an enum but try to pull the resources from the front-end code if possible.

Note that these tests will need to connect to the internet, so we'll likely want a longer timeout on pageload time. Additionally, we may want to test if we're connected to the network and, if not, skip over this test so it doesn't cause annoying intermittents.
Whiteboard: [mentor=mcomella][lang=java]
This should really be a unit test so we should wait until bug 856614 lands.
Depends on: 856614
Hi
I would like to work on this bug. Can u help me on it?
(In reply to Ameya from comment #3)
> Hi
> I would like to work on this bug. Can u help me on it?

Unfortunately, I think we need to wait for bug 709353 to land (which will likely be a while) before this bug can be worked on. bug 963352 is a similar bug you might be interested in working on.
Depends on: 709353
Forward-duping to bug 997485.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 997485
You need to log in before you can comment on or make changes to this bug.