Browser hang, when you clicked left upper red "Gmail"

VERIFIED FIXED in Firefox 28

Status

()

defect
--
critical
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: alice0775, Assigned: surkov)

Tracking

({hang, regression})

28 Branch
mozilla30
x86_64
Windows 8.1
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox27 unaffected, firefox28+ fixed, firefox29+ fixed, firefox30+ verified, b2g-v1.3 fixed, b2g-v1.3T fixed, b2g-v1.4 fixed)

Details

Attachments

(1 attachment)

Build Identifier:
https://hg.mozilla.org/mozilla-central/rev/cafe909f7e07
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 ID:20140208030207

This hang happens on Windows8.1 only. 
Not reproduce on Wndows7.


Stack on hang : bp-993fe2d6-c1c7-4a50-815a-7c5082140209

Steps To Reproduce:
1. Open https://mail.google.com and sign-in
2. Click red "Gmail" at the left-upper

Actual Results:
Browser freezes

Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/16949049f03d
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131110030205
Bad:
http://hg.mozilla.org/mozilla-central/rev/86afe33114e7
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131110235419
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=16949049f03d&tochange=86afe33114e7


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/c8d6e8deac02
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131108160815
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/b4a630050f61
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131108162618
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c8d6e8deac02&tochange=b4a630050f61

Regressed by:
b4a630050f61	Alexander Surkov — Bug 933322 - menustart/end events are missing when aria-owns makes a menu hierarchy, r=tbsaunde
I can confirm this using Nightly 30.0a1 (2013-02-08). Unfortunately it didn't crash, I had to kill it via Task Manager, so I don't have a Crash Reporter ID. Alex, it's the drop down button in the Gmail interface, not the one directly above the Search field. I was running with NVDA.
I have this bug also.
Note my platform is x86. It is Asus T100.

Firefox beta x86 28

Mozilla/5.0 (Windows NT 6.3; rv:28.0) Gecko/20100101 Firefox/28.0

The browser  also hangs when i tick some mail, click "More" and "Mark as read".
Duplicate of this bug: 970270
Duplicate of this bug: 970010
Duplicate of this bug: 969755
Duplicate of this bug: 970089
So, what I think is happening here is that some element has aria-owns=<element for child accessible> so then at FocusManager.cpp:312 we get the element that owns child, and set parent to point at that.  Then if parent has nothing to do with menus we repeat parent = <element owning <child> which is an endless loop afaict I'm not sure how best to fix this, maybe get the element owning parent that way we always move up (except that might still break with screwy markup that has an element aria-own its parent? I think I'll let Alex decide how to fix this ;)
I think it is safe to not support a child aria-owning an ancestor. In any event we need to be cycle proof.
Posted patch patchSplinter Review
Assignee: nobody → surkov.alexander
Attachment #8373524 - Flags: review?(trev.saunders)
Attachment #8373524 - Flags: review?(trev.saunders) → review+
Comment on attachment 8373524 [details] [diff] [review]
patch

>-    //gA11yEventDumpToConsole = true; // debuging
>+    gA11yEventDumpToConsole = true; // debuging

Alex, did you disable that again before landing?
(In reply to Marco Zehe (:MarcoZ) from comment #11)
> >-    //gA11yEventDumpToConsole = true; // debuging
> >+    gA11yEventDumpToConsole = true; // debuging
> 
> Alex, did you disable that again before landing?

Yes, he did.
(In reply to Tim Taubert [:ttaubert] from comment #12)
> Yes, he did.

Thanks, Tim! :)
https://hg.mozilla.org/mozilla-central/rev/3e9c4bb1ce40
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
Comment on attachment 8373524 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 933322 
User impact if declined: Firefox hangs on certain sites (gmail is one example)
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): small
String or IDL/UUID changes made by this patch: no
Attachment #8373524 - Flags: approval-mozilla-beta?
Attachment #8373524 - Flags: approval-mozilla-aurora?
Attachment #8373524 - Flags: approval-mozilla-beta?
Attachment #8373524 - Flags: approval-mozilla-beta+
Attachment #8373524 - Flags: approval-mozilla-aurora?
Attachment #8373524 - Flags: approval-mozilla-aurora+
Keywords: checkin-needed
I can't reproduce the initial issue on Nightly 30.0a1 (2013-02-08), Win 8.1 32/64 bit.
Alice, can you please confirm it's fixed for you in the latest nightly ?
Flags: needinfo?(alice0775)
I cannot reproduce anymore.
https://hg.mozilla.org/mozilla-central/rev/e5b09585215f
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 ID:20140305030201
Flags: needinfo?(alice0775)
Thank you, Alice.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.