Closed Bug 970026 Opened 7 years ago Closed 7 years ago

History Footer button should be fixed at the bottom of the subview

Categories

(Firefox :: Toolbars and Customization, defect)

30 Branch
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 --- fixed
firefox30 --- verified

People

(Reporter: ntim, Assigned: jaws)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:P3][fixed by bug 966905])

Attachments

(1 file)

Adding flex="1" to #PanelUI-historyItems fixes the issue.
Whiteboard: [Australis:P4]
(In reply to Tim Nguyen [:ntim] from comment #0)
> Adding flex="1" to #PanelUI-historyItems fixes the issue.

Can we start with steps to reproduce, please? How do I get it to not be fixed at the bottom? What does it look like when it isn't? :-)

(also, please make australis bugs you file block 'something', like 'australis-cust' (for customization/panel-related things) or 'australis-tabs-osx/win/linux' (for tabs-related things))
Flags: needinfo?(ntim007)
Keywords: regression
Sorry, here's the info you need :
STR :
- Put the history widget in panel menu
- Click on it
- Make sure you don't have much history items
- You can see that the footer "Show All History" is not fixed at the bottom of the subview
Flags: needinfo?(ntim007)
Attached image Screenshot
It looks even worse when there are no history items.
Blocks: 966905
Whiteboard: [Australis:P4] → [Australis:P3]
Actually, bug 966905 isn't on m-c and I can reproduce on m-c, so I guess that's not it.
No longer blocks: 966905
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
It is because the mainview is taller than the subview, as you can see in the screenshot.
(In reply to Tim Nguyen [:ntim] from comment #0)
> Adding flex="1" to #PanelUI-historyItems fixes the issue.

FWIW, given the discussion in bug 947488, I'm somewhat worried that doing that will cause the same issue to start happening with the history subview. Between the two problems, I'd pick this one.
(In reply to :Gijs Kruitbosch from comment #6)
> (In reply to Tim Nguyen [:ntim] from comment #0)
> > Adding flex="1" to #PanelUI-historyItems fixes the issue.
> 
> FWIW, given the discussion in bug 947488, I'm somewhat worried that doing
> that will cause the same issue to start happening with the history subview.
> Between the two problems, I'd pick this one.

The subview footer is now fixed at the bottom in latest nightly.
Then it was probably fixed by bug 966905. :-)
Assignee: nobody → jaws
Blocks: 966905
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3] → [Australis:P3][fixed by bug 966905]
Target Milestone: --- → Firefox 30
Reproduced in Nightly 2014-02-08.
Verified fixed 30.0a1(2014-02-11), Win 7 x64.
Status: RESOLVED → VERIFIED
Now fixed on 29 since the patch for bug 966905 has been uplifted to Aurora.
You need to log in before you can comment on or make changes to this bug.