Closed Bug 970377 Opened 7 years ago Closed 7 years ago

[Messages][Drafts] Drafts are kept forever

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.4+, b2g-v1.4 fixed)

RESOLVED FIXED
1.4 S2 (28feb)
blocking-b2g 1.4+
Tracking Status
b2g-v1.4 --- fixed

People

(Reporter: gerard-majax, Assigned: rwaldron)

References

Details

Attachments

(1 file)

Drafts are always kept in the message thread when sending new SMS. Reproducing with gecko/gaia master (8937359/0d080de).

STR:
 0. Go in a SMS thread
 1. Start a message, leave the thread. This should create a draft
 2. Close the application, restart it
 3. Draft is still in the thread
 4. Open again the thread
 5. Draft content is added in the input field
 6. Erase the input, send a SMS and close the application
 7. Start again the application

Expected:
 There is no more draft in the thread

Actual:
 Draft from step (1) is still in the thrad
Summary: Drafts are kept forever → [Messages][Drafts] Drafts are kept forever
Duplicate of this bug: 972498
triage: major usability issue 1.4+
blocking-b2g: 1.4? → 1.4+
Assignee: nobody → waldron.rick
Comment on attachment 8379875 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/16529

r=me with one comment

thanks !

please land on a green travis
Attachment #8379875 - Flags: review?(felash) → review+
(In reply to Julien Wajsberg [:julienw] from comment #4)
> Comment on attachment 8379875 [details] [review]
> https://github.com/mozilla-b2g/gaia/pull/16529
> 
> r=me with one comment
> 
> thanks !
> 
> please land on a green travis

Will do!

Here is the new travis link: https://travis-ci.org/mozilla-b2g/gaia/builds/19356752
Issues with a leaky sinon spy needed to be addressed, new travis link: https://travis-ci.org/mozilla-b2g/gaia/builds/19361751
https://github.com/mozilla-b2g/gaia/commit/7742135d6f1204f28145d8bc716f52fa67c70344
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.4 S2 (28feb)
You need to log in before you can comment on or make changes to this bug.