Re-implement Small Icon Mode

VERIFIED WONTFIX

Status

()

Firefox
General
VERIFIED WONTFIX
4 years ago
4 years ago

People

(Reporter: Tyler, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Australis:P-])

(Reporter)

Description

4 years ago
In surveying thousands of users on Australis, one theme that consistently appears is the lack of a small icon mode. While Australis is overall very space conscience, there are users who would like a mode that shrinks the vertical height of the back button to the same as the url bar, and possibly reduces some of the other padding going on in the UI. Adding this feature back in will help ease user pain around Australis.

Comment 1

4 years ago
Even if we do want to consider this from a UX/Product perspective, from an engineering perspective, I strongly believe this isn't feasible for 29 anymore.
Whiteboard: [Australis:P-]
Blocks: 939862

Comment 2

4 years ago
Just shrink the vertical padding in a few places and most people would be fine with it.

In my opinion, the best way to deal with the removal of small icons mode would be to have various compact full themes that support Australis available and promoted on AMO when it makes it to the public release. The message to users when they complain about the removal of small icons mode is that it makes the browser less complicated to have each theme have one size, rather than two, so just separately install the one you want.

Comment 3

4 years ago
Also, putting a link to AMO for new themes directly in the UI customization UI sounds like a good idea.
This is indeed out-of-scope for Australis at this point. We've also previously discussed the issue leading up to the removal, and I don't see any need to revisit that decision.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
Status: RESOLVED → VERIFIED
Duplicate of this bug: 995724

Comment 6

4 years ago
I tottally agree with the reimplementation of the small icons, which is one of my favorite customizations in FF. Maybe in future versions we can get it back?

Updated

4 years ago
Duplicate of this bug: 1003533
Comment hidden (abusive)
You need to log in before you can comment on or make changes to this bug.