Checkboxes doesn't trigger properly, with edges gesture enabled

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: kelvincobanaj22, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.107 Safari/537.36

Steps to reproduce:

I enabled "Edges gesture" option in developer settings.


Actual results:

When you tap on checkboxes they doesn't trigger, but instead it trigger other checkboxes.


Expected results:

Trigger the checkbox that was tapped.
Confirmed, with enabled Edge gestures on Peak with latest v1.3 build, go to Settings > Display, then tap on the "Auto adjust" checkbox: it triggers the Select wallpaper prompt (above setting).

Note, be sure to tap on the checkbox itself.
Status: UNCONFIRMED → NEW
blocking-b2g: --- → 1.3?
Ever confirmed: true
Clearing nom - edge gestures is shipping as a disabled feature, so this is not a blocker.
Blocks: 918792
blocking-b2g: 1.3? → ---
This was an APZC issue and it got fixed but sadly I can't find the bug #.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
This bug seems to be back.

Build Information
Gaia      ef66efa34ed8a559c8998bde688fae88eb943a7a
Gecko     https://hg.mozilla.org/mozilla-central/rev/b40296602083
BuildID   20140522040230
Version   32.0a1
ro.build.version.incremental=94
ro.build.date=Tue May 20 09:29:20 CST 2014

Step to reproduce
Flash the device to this version (Edge gesture are enabled by default).
Launch the Settings app.
Go to Keyboard, Selected Keyboards, Add more keyboards
Check and uncheck some checkboxes

Actual result
Sometimes, when tapping a checkbox, one checkbox above is check

Reproducibility rate: ~10% - 20%

Additional notes: When deactivating the Edge gesture feature, I was unable to reproduce the problem with the same number of tries (15).
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
This bug seems to be back on the Flame on 2.0.
There's already a new bug on this. See bug 984897.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.