Closed Bug 984897 Opened 6 years ago Closed 5 years ago

Pressing on the edge of the screen misbehaves for HiDPI screens

Categories

(Core :: IPC, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla32
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- fixed

People

(Reporter: rik, Assigned: vingtetun)

References

Details

(Keywords: regression, Whiteboard: [systemsfe])

Attachments

(1 file)

STR on a Peak with edge gestures activated:
1) Go to Settings>Display
2) Tap the checkbox for Adjust automatically

Actual:
It opens the wallpaper selection menu

Expected:
Adjust automatically is toggled

If you disable edge gestures, it works as expected. If you tap the adjust automatically line, it works as expected.
It also prevents index scrolling on the alphabet in the Contacts app.
I believe this is also making the send button in the SMS app very hard to tap when the keyboard is opened.
Blocks: 991849
Summary: Pressing checkboxes on the edge of the screen misbehaves → Pressing checkboxes on the edge of the screen misbehaves for HiDPI screens
feature-b2g: --- → 2.0
Can we get a video showing the bug here on the latest trunk?
Blocks: edge-gestures
No longer blocks: 991849
Keywords: qawanted
For QA, this only happens on hidpi devices. (I updated the title a bit late)
Duplicate of this bug: 1010421
Dupe clarifies this is happening on our reference implementation.
blocking-b2g: --- → 2.0?
Keywords: qawantedregression
Also - this is not a feature implementation piece, this is classified as a regression from turning on edge gestures.
feature-b2g: 2.0 → ---
Whiteboard: [systemsfe]
Component: Gaia → Gaia::System::Window Mgmt
IIRC this is a APZC issue, we might even have a dup.
Component: Gaia::System::Window Mgmt → Panning and Zooming
Product: Firefox OS → Core
See https://bugzilla.mozilla.org/show_bug.cgi?id=1010421#c3
Component: Panning and Zooming → Gaia::System::Window Mgmt
Product: Core → Firefox OS
Duplicate of this bug: 1011102
Summary: Pressing checkboxes on the edge of the screen misbehaves for HiDPI screens → Pressing on the edge of the screen misbehaves for HiDPI screens
Any ETA for this? Zoom, On screen UI and touch to focus are affected by this in the camera app.
Hi Gregor, it belongs to system fe, can you do the triage?
Flags: needinfo?(anygregor)
I didn't tried the patch but Etienne told me that it fix the issue for him on the Nexus 4.
Attachment #8428764 - Flags: review?(bugmail.mozilla)
Comment on attachment 8428764 [details] [diff] [review]
fix.injecttouchevent.patch

Review of attachment 8428764 [details] [diff] [review]:
-----------------------------------------------------------------

My only concern is that some marionette tests might be using this function on HiDPI devices, and might break because of this change. We should keep an eye out for any Marionette failures after this lands.

::: dom/ipc/TabParent.cpp
@@ +2003,5 @@
> +  nsIDocument* doc = content->OwnerDoc();
> +  if (!doc || !doc->GetShell()) {
> +    return NS_ERROR_FAILURE;
> +  }
> +  nsPresContext* presContext = doc->GetShell()->GetPresContext();

Eventually we should refactor this boilerplate into a helper method. But no need to do that in this patch if you don't want to.

@@ +2009,3 @@
>    event.touches.SetCapacity(aCount);
>    for (uint32_t i = 0; i < aCount; ++i) {
> +    LayoutDeviceIntPoint pt = 

nit: trailing whitespace
Attachment #8428764 - Flags: review?(bugmail.mozilla) → review+
blocking-b2g: 2.0? → 2.0+
Flags: needinfo?(anygregor)
Duplicate of this bug: 1016718
I'll push this (with nit fixed) as soon as the tree reopens.
Duplicate of this bug: 1016670
Duplicate of this bug: 1013629
Component: Gaia::System::Window Mgmt → IPC
Product: Firefox OS → Core
Version: unspecified → Trunk
https://hg.mozilla.org/mozilla-central/rev/d0cd763cc5e8
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla32
Assignee: nobody → 21
Duplicate of this bug: 1094657
You need to log in before you can comment on or make changes to this bug.