Closed Bug 970860 Opened 7 years ago Closed 5 years ago

[TSF] Candidate/suggest window of Google Japanese Input isn't positioned properly

Categories

(Core :: Widget: Win32, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1061604

People

(Reporter: masayuki, Assigned: masayuki)

References

Details

(Keywords: inputmethod)

According to the information from Yukawa-san who is a developer of Google Japanese Input, TSF has a bug.

In TSF mode, Gecko doesn't reflow the layout with composition changes coming from TIP immediately. Until actually changing the layout, Gecko returns TS_E_NOLAYOUT from nsTextStore::GetACPFromPoint() and nsTextStore::GetTextExt(). However, TSF returns E_FAIL to TIP only when TIP accesses GetTextExt().

This is the cause of Google Japanese Input fails to get composition string position with GetTextExt().

This TSF's bug has already been reported to MS by Yukawa-san. However, Yukawa-san said that he will try to use GetACPFromPoint() if GetTextExt() returns TS_E_NOLAYOUT for non-patched Windows.

Luckily, we return TS_E_NOLAYOUT from GetACPFromPoint() while the layout hasn't been updated even though we hasn't implemented it yet (see bug 492394). Not for breaking this behavior, at least, we should add comment to prevent that other developers won't remove it.
I confirmed that this bug has gone on Win10. Looks like the bug of TSF is fixed on Win10.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1061604
You need to log in before you can comment on or make changes to this bug.