[MSFT-7923] [MSFT-10204] [TSF] enable TSF support in default prefs on Vista or later

RESOLVED FIXED in Firefox 41

Status

()

RESOLVED FIXED
10 years ago
2 years ago

People

(Reporter: masayuki, Assigned: masayuki)

Tracking

(Blocks: 1 bug, {inputmethod, intl, meta})

Trunk
mozilla41
x86
Windows 8
inputmethod, intl, meta
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox40 wontfix, firefox41 fixed, relnote-firefox 41+)

Details

Attachments

(1 attachment)

Jim Chen implemented TSF support on Windows in bug 88831. However, there are some blocker bugs for IME users. Therefore, currently, TSF support is disabled by default prefs.

You can test TSF support by to change "intl.enable_tsf_support" to true.
(Assignee)

Updated

10 years ago
Depends on: 478030

Updated

10 years ago
Depends on: 478146
(Assignee)

Updated

10 years ago
No longer depends on: 478146

Updated

10 years ago
Depends on: 478880

Updated

10 years ago
Depends on: 478882

Updated

10 years ago
Depends on: 478884

Updated

10 years ago
Depends on: 478885

Updated

10 years ago
Depends on: 478887
(Assignee)

Updated

10 years ago
No longer depends on: 478882

Updated

10 years ago
Depends on: 480111
(Assignee)

Updated

10 years ago
No longer depends on: 478880, 478887
(Assignee)

Updated

10 years ago
Depends on: 482138
We have to fix following bugs at least for this bug.

1. bug 482138
MS Natural Input is only using TF_ATTR_OTHER for the attribute of composition string and it specifies several styles for composition string. Therefore, users can know/see the difference of meaning of each clauses of composition string by the difference of the styles. I'll finish first patch of this bug soon.

2. MS Natural Input doesn't work fine in most cases
In bugzilla-jp, some testers reported many strange bugs which are reproduced with MS Natural Input. I guess that our composition start/end timing is not enough. I think that we need to redesign the composition transaction management in nsTextStore.

3. Win2k + MS Office
I don't test this case yet. However, Japanese testers reported some critical bugs. E.g., bug 478884 and bug 478885. I need to check them. If they can fix without big changes, we can ignore them for this bug. Otherwise, they should block this bug.
The 2 is worked on bug 480708.
Depends on: 480708

Comment 3

10 years ago
If you need any help with #1 & #2 Masayuki, I'd be more than happy to help. 2K issues are for the most part are now non-blockers for 1.9.2.
Yes, now we can ignore #3 at this bug. But we still need to check the bug after this, because that may tell us the hidden bugs on XP and later.

I think bug 482138 will be fixed in this several weeks. I don't find the goal of bug 480708 yet. But it should be found in this several weeks.
No longer depends on: 478884, 478885
Summary: [TSF] enable TSF support in default prefs → [MSFT-7923] [TSF] enable TSF support in default prefs
Have we considered fixing this for 1.9.1?
Adding tracking links for issues reported by Microsoft.
Summary: [MSFT-7923] [TSF] enable TSF support in default prefs → [MSFT-7923] [MSFT-10204] [TSF] enable TSF support in default prefs
(In reply to comment #5)
> Have we considered fixing this for 1.9.1?

No, we gave up already. See bug 88831 comment 80. And we need to fix very many bugs until final release of our TSF support.

Updated

9 years ago
Blocks: 488715

Updated

9 years ago
Depends on: 502265

Comment 9

9 years ago
Masayuki, For 3.6, could we potentially enable TSF by default for os/language combinations that don't have major unresolved issues? For example, it doesn't look like latin systems have issues, so maybe we could enable TSF for these systems that also support tablet or touch enabled displays?
No, it shouldn't be. Even if the system locale is not CJK, the systems can be used CJK local IMEs. And some users use them.

We should disable TSF on 3.6. By the 1.9.2 release date was changed to this fall, I needed to change the roadmap of my works, unfortunately.
Depends on: 496360
Depends on: 544769
Keywords: inputmethod

Updated

7 years ago
Depends on: 650833

Comment 11

7 years ago
Vista has come and gone and Windows speech recognition never worked in Firefox or Thunderbird under that operating system.  I filed bug report 395484 in September 2007 - getting on for four years ago.

Windows 7 has been current for around two years and still TSF isn't working in either of the above Mozilla applications.  

The last posting in this thread was nearly two years ago.

Even if I enable TSF speech recognition doesn't work well enough to be useful.  At the suggestion of  Jim Mathies I have filed a separate bug report, 650833, on the loss of focus.

It won't be so long before Windows 8 is with us and as Jim has pointed out, "tablet / touch input support is going to be *real* important with Win8"

Is it possible to provide an estimate of when work might start on fixing the problem both Firefox and Thunderbird?  Hopefully this will be before Windows 9 is upon us…

Updated

6 years ago
OS: Windows Vista → Windows 8

Updated

6 years ago
Blocks: 785534
Depends on: 789706
Depends on: 789708
Depends on: 805766
I think that when we enable TSF in default settings, we should keep disabling TSF on prior to Vista because the TSF framework on XP has a lot of different behavior. Additionally, MS's Natural Input 2002 which is bundled and behaves much complicated.
(In reply to Masayuki Nakano (:masayuki) (Mozilla Japan) from comment #12)
> Additionally, MS's Natural Input 2002 which is bundled
> and behaves much complicated.

I meant that it's bundled to only XP and it behaves much complicated. So, it's hard to support it and XP will be end of its life cycle even though we'll keep supporting it.
No longer depends on: 480708
Depends on: 961703
Depends on: 961704
Depends on: 962920
Depends on: 964623

Updated

5 years ago
Depends on: 968647
Depends on: 970860
Depends on: 971393

Updated

4 years ago
Depends on: 995893
Depends on: 492394, 544777, 826657
Depends on: 1037328
Depends on: 596507
Depends on: 1049488
No longer depends on: 970860
Depends on: 1060768
Depends on: 1137539
No longer depends on: 1060768
Depends on: 1149428
Created attachment 8592143 [details] [diff] [review]
Enable TSF in release builds
Summary: [MSFT-7923] [MSFT-10204] [TSF] enable TSF support in default prefs → [MSFT-7923] [MSFT-10204] [TSF] enable TSF support in default prefs on Vista or later
Comment on attachment 8592143 [details] [diff] [review]
Enable TSF in release builds

Right now, the final blocker of this bug has been fixed!

Let's enable TSF in release builds.

Currently, we've already enabled TSF mode in Aurora (38). Therefore, it's now being tested wider than 37. If somebody will file serious bugs of TSF mode, we can back this out from future branches or m-c.

So, I think that it is the time to land this patch!
Attachment #8592143 - Flags: review?(m_kato)
Attachment #8592143 - Flags: review?(jmathies)
Attachment #8592143 - Flags: review?(VYV03354)

Comment 16

3 years ago
Comment on attachment 8592143 [details] [diff] [review]
Enable TSF in release builds

How is TSF behaving with e10s currently?
Attachment #8592143 - Flags: review?(jmathies) → review+
(In reply to Jim Mathies [:jimm] from comment #16)
> Comment on attachment 8592143 [details] [diff] [review]
> Enable TSF in release builds
> 
> How is TSF behaving with e10s currently?

With e10s, TSF is disabled. When you enable TSF mode with e10s mode, you need to enable "intl.tsf.force_enable". See bug 1147722.
Comment on attachment 8592143 [details] [diff] [review]
Enable TSF in release builds

\o/
Attachment #8592143 - Flags: review?(VYV03354) → review+
Comment on attachment 8592143 [details] [diff] [review]
Enable TSF in release builds

great!
Attachment #8592143 - Flags: review?(m_kato) → review+
https://hg.mozilla.org/mozilla-central/rev/c0c4d56594f9
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox40: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
Depends on: 1181042
Depends on: 1187566
Release Note Request (optional, but appreciated)
[Why is this notable]: TSF support is a big change for IME users of Windows because it supports a lot of features which cannot be supported with IMM. And also some a11y tools can use TSF for querying editing contents.
[Suggested wording]: Firefox 41 supports TSF (Text Services Framework). This provides better UX for IME users of Windows.
[Links (documentation, blog post, etc)]: Nothing.

# TSF is new IME framework on Windows. This allows IME to access full contents of editing field. So, they can improve conversion result from surrounding text. And also we can give native look of composition string with TSF's new feature.
status-firefox40: fixed → wontfix
status-firefox41: --- → fixed
relnote-firefox: --- → ?
Target Milestone: mozilla40 → mozilla41
Added to FF41 release notes.
relnote-firefox: ? → 41+

Comment 24

3 years ago
As many are probably unaware what TSF is, please change the relnotes thusly:

[Suggested wording]: Enhance IME support on Windows (Vista +) using TSF (Text Services Framework)
Flags: needinfo?(rkothari)
(In reply to Florian Bender from comment #24)
> As many are probably unaware what TSF is, please change the relnotes thusly:
> 
> [Suggested wording]: Enhance IME support on Windows (Vista +) using TSF
> (Text Services Framework)

Done.
Flags: needinfo?(rkothari)

Updated

3 years ago
Depends on: 1206387

Updated

2 years ago
Depends on: 1339331
You need to log in before you can comment on or make changes to this bug.