Firefox claims it is already running when it isn't; won't open a window

RESOLVED DUPLICATE of bug 1005487

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 1005487
4 years ago
4 years ago

People

(Reporter: Gerry, Unassigned)

Tracking

({qawanted})

29 Branch
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugday-20140217])

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8374058 [details]
Screenshot.png

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20140130133743

Steps to reproduce:

1) a firefox window is open
2) I close firefox window
3) later on I want to browse the web and click the Firefox icon to open a firefox window



Actual results:

1) a message pops up saying Firefox is already running; a firefox window will not open
2) the only way to get firefox to open a window is to go to Terminal and input "killall firefox" command and then it will open a window


Expected results:

Firefox should not lockup. If no windows are open and user clicks Firefox icon, a new window should open.
Does it also happen with a new profile ?
http://support.mozilla.org/kb/Managing%20profiles
(Reporter)

Comment 2

4 years ago
Yeah, it happens with a new profile.

Please understand, this issue does not occur every single time I close Firefox and try to open it. But it does occur often enough that it is problematic. For example, my elderly parents stop using Firefox when it does this. They have trouble figuring out how to close the process so they just don't use it. I'll come by and fix it for them, but at some point it will "lock up" again. If I create a new profile, it's just a matter of time before it's done it again.
Do you use extensions/addons ?
This usually happens with some stuff like addons that are installed from anti-virus software (on windows) or other extensions and plugins. There is not much that we could do without steps to reproduce (and in this case this seem to be impossible) or if a developer gets this issue on his system to debug it.

Comment 4

4 years ago
If Firefox hangs, maybe killing it with "-ILL" to get a crash report will be useful.  Then, please post here the crash id from about:crashes.
Whiteboard: [bugday-20140217]

Comment 5

4 years ago
This bug has started affecting me since I updated to v29. Could someone look at it? Be nice if it was fixed. I have to killall firefox literally everytime I want to open the browser.

here's an about:crashes report:
https://crash-stats.mozilla.com/report/index/f573afb8-6594-45c7-bc9a-d90b12140430
I can repro on win too.
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: x86_64 → All
Version: 27 Branch → 29 Branch

Updated

4 years ago
Duplicate of this bug: 1000155

Updated

4 years ago
Duplicate of this bug: 1002765

Comment 9

4 years ago
don't know if it matters, but I've been able to repro this bug on Firefox versions prior to v27. This bug has existed for a long time. v29 seems to have made it worse (happen more often).

Comment 10

4 years ago
apparntly clear on exit functions is what is causing this to happen in 29.

Comment 11

4 years ago
(In reply to MikeLMann from comment #9)
> don't know if it matters, but I've been able to repro this bug on Firefox
> versions prior to v27. This bug has existed for a long time. v29 seems to
> have made it worse (happen more often).

Fx27 and Fx28 were fine for me. Will retry with both to confirm. Can you try with the STR from bug 1000155 and see if it reros for you?

Comment 12

4 years ago
(In reply to Arthur K. from comment #11)
> (In reply to MikeLMann from comment #9)
> > don't know if it matters, but I've been able to repro this bug on Firefox
> > versions prior to v27. This bug has existed for a long time. v29 seems to
> > have made it worse (happen more often).
> 
> Fx27 and Fx28 were fine for me. Will retry with both to confirm. Can you try
> with the STR from bug 1000155 and see if it reros for you?

An STR that "guarantees" reproduction of the bug so far has eluded me. But now that I've been actively looking for this bug and experimenting to find its occurrence, I have been able to repro on both v27 and v28. I've even been able to reproduce the bug using version 10.04 of Ubuntu with a firefox version in the teens! Although it is "hard" to "find" the bug on versions prior to v29, it is def there. v29 has made it a common occurrence. Prior to v29, its occurrence was rare. Nonetheless, this bug's genesis was not v29.

Interestingly, I have not been able to repro the bug on Windows OS prior to v29 of firefox. Has anyone been able to repro on Windows prior to v29?

Comment 13

4 years ago
i'm on windows 7 and have been able to reproduce it somewhat semi-reliably with a new profile, setting privacy.sanitize.sanitizeOnShutdown to true and a twitter search as homepage page. 

when i then open the browser, wait until the page is loaded, hover over some links and close the browser at the same time (alt+f4) then in some instances it won't shut down properly. when i let the Process Monitor from http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx run at the same time, it always shows that "netpredictions.sqlite" is the last file in the profile that's written to. (i will attach a screencast of the procedure and a logfile from Process Monitor).

this can be reproduced semi-reliably on versions 29-32 and regardless if network.seer.enabled is set to true or false.

Comment 14

4 years ago
Created attachment 8417109 [details]
Logfile.PML

Comment 15

4 years ago
Created attachment 8417110 [details]
screencast.avi

Comment 16

4 years ago
I have narrowed this down to clearing "Active Logins" on exit and the active log-in in question tends to be Gmail.

Updated

4 years ago
Component: Untriaged → General
Keywords: qawanted
I have been trying to reproduce the problem on Win7/Fx29 using the steps in comment #13 and also the information in other comments such as comment #16, but I have not been able to reproduce the problem yet.

Comment 18

4 years ago
I have the same problem intermittently with Firefox 29 in Windows 7 x64. My settings are:

Firefox will: Use custom settings for history
[ ] Always use private browsing mode
[X] Remember my browsing and download history
[ ] Remember search and form history
[X] Accept cookies from sites
[X] Clear history when Firefox closes

The problem goes away when I turn off "Clear history when Firefox closes".

Comment 19

4 years ago
I can also confirm this exactly issue on Firefox 29 (32 bits) and Windows XP (both 32 and 64 bits). As other reporters, disabling "[ ] Clear history when Firefox closes" mitigates the problem.

Updated

4 years ago
QA Whiteboard: [qa+]
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1005487

Comment 21

4 years ago
(In reply to MikeLMann from comment #12)
> (In reply to Arthur K. from comment #11)
> > (In reply to MikeLMann from comment #9)
> > > don't know if it matters, but I've been able to repro this bug on Firefox
> > > versions prior to v27. This bug has existed for a long time. v29 seems to
> > > have made it worse (happen more often).
> > 
> > Fx27 and Fx28 were fine for me. Will retry with both to confirm. Can you try
> > with the STR from bug 1000155 and see if it reros for you?
> 
> An STR that "guarantees" reproduction of the bug so far has eluded me. But
> now that I've been actively looking for this bug and experimenting to find
> its occurrence, I have been able to repro on both v27 and v28. I've even
> been able to reproduce the bug using version 10.04 of Ubuntu with a firefox
> version in the teens! Although it is "hard" to "find" the bug on versions
> prior to v29, it is def there. v29 has made it a common occurrence. Prior to
> v29, its occurrence was rare. Nonetheless, this bug's genesis was not v29.
> 
> Interestingly, I have not been able to repro the bug on Windows OS prior to
> v29 of firefox. Has anyone been able to repro on Windows prior to v29?

I have not. Don't know if it makes any difference but it seems, in my case, when I load pages that fire up the Flash plugin, it seems to happen most. This is not to imply Flash is the *cause* of the issue. I had the initial experience of it happening more with an older version (11.8) of Flash and less so with Flash 13.x. I'm still trying to find a 100% reliable repro.

Comment 22

4 years ago
Still observing this on 29.0.1 build2.

Comment 23

4 years ago
I have the same problem with firefox 29 on Kubuntu 14.04.

Comment 24

4 years ago
(In reply to lezburg@free.fr from comment #23)
> I have the same problem with firefox 29 on Kubuntu 14.04.

If you privacy.sanitize.sanitizeOnShutdown to false, does it still happen?

Comment 25

4 years ago
I resolved it by checking "Remember my browsing and download history" in privacy settings!

Comment 26

4 years ago
I can reproduce every time in 29 by going to https://support.dish.com/index.php and closeing the browser the exe will remain running.

I have Clear history on exit enabled
You need to log in before you can comment on or make changes to this bug.