Closed Bug 971352 Opened 11 years ago Closed 10 years ago

file menu locks up when sync door hanger drops

Categories

(Firefox :: Sync, defect)

x86
macOS
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 968435

People

(Reporter: edwong, Unassigned)

References

Details

1. on nightly, setup sync
2. create acct or sign in
3. quickly right after you sign in, click on file menu so that any of the menus drop down

actual: door hanger drops, and file menu is locked, you can select anything in the file menu area.

work around - clicking away fixes it.
low-ish priority, but we should be aware of this.
Blocks: 969593
Severity: normal → minor
What does "File menu is locked" mean?
(potentially related: bug 966098)
:gavin i.e. you can select anything in the file menu area, menu's don't drop down when hovered over.
(In reply to :Gavin Sharp (email gavin@gavinsharp.com) from comment #3)
> (potentially related: bug 966098)

Yeah, I agree. Maybe we should put this all into a bug that is about how to determine when it's good when to show the doorhangers to ensure users see it without annoying them. Bug 966098 is probably that.
(In reply to Tim Taubert [:ttaubert] from comment #5)
> Yeah, I agree. Maybe we should put this all into a bug that is about how to
> determine when it's good when to show the doorhangers to ensure users see it
> without annoying them. Bug 966098 is probably that.

I'm not sure I understand - in this scenario the window is in the foreground and being interacted with by the user, so now seems a perfect time to show the doorhanger.  Unless you are suggesting we wait until the user is not interacting with a foreground Fx - but I'd argue that probably means they've stepped away from their computer :)

I wonder if the problem is the nested event loops sync runs - if the menu is up when a nested loop starts I'd expect some problems (and have seen problems relating to interacting with the window in the past when unhandled errors occurred in this state).  Either way, I can't repro this on Windows.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.