Closed Bug 968435 Opened 10 years ago Closed 10 years ago

"Now Syncing" doorhanger displays over other applications

Categories

(Firefox :: Sync, defect)

29 Branch
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 + verified
firefox30 --- verified

People

(Reporter: rnewman, Assigned: markh)

References

Details

(Keywords: polish, Whiteboard: [qa!])

Attachments

(1 file)

Firefox has a long-standing problem with doing this all the damn time -- e.g., with tooltips on links (Bug 148624).

Open Firefox after setting up FxA Sync. Switch to terminal. Wait a minute. See doorhanger on top of my terminal.
Blocks: 905997
Windows too.
OS: Mac OS X → All
Whiteboard: [qa+]
The problem is that the panels have an attribute level="top", which means on top of windows from other applications.  level="parent" is the behaviour we want, but https://developer.mozilla.org/en-US/docs/XUL/panel cautions about using this - it says we should just rely on the default.  This means that in theory, Linux will still display on top of other windows, but presumably the default for that platform exists for a reason - so this patch just removes the attribute entirely.  This fixes the problem for me on Windows, but I've not tested other platforms.
Assignee: nobody → mhammond
Status: NEW → ASSIGNED
Attachment #8375299 - Flags: review?(ttaubert)
Whiteboard: [qa+] → p=0 [qa+]
Comment on attachment 8375299 [details] [diff] [review]
Remove 'level' attribute from sync panels

Review of attachment 8375299 [details] [diff] [review]:
-----------------------------------------------------------------

Yeah, the Australis team did the same recently, iirc.
Attachment #8375299 - Flags: review?(ttaubert) → review+
https://hg.mozilla.org/mozilla-central/rev/a39438d36c9a
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
No longer blocks: fxdesktopbacklog
Whiteboard: p=0 [qa+] → [qa+]
Comment on attachment 8375299 [details] [diff] [review]
Remove 'level' attribute from sync panels

[Approval Request Comment]
Bug caused by (feature/regressing bug #): FxA sync
User impact if declined: Sync panel may appear over other windows
Testing completed (on m-c, etc.): Landed on MC
Risk to taking this patch (and alternatives if risky): Low
String or IDL/UUID changes made by this patch: None
Attachment #8375299 - Flags: approval-mozilla-aurora?
Attachment #8375299 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified the door hanger is no longer on top on latest Nightly and Aurora.  

However, since clicking anywhere dismisses the dialog, it is not seen. 

Well, sort of.

I used a terminal with a small amount of transparency to reproduce rnewmans original steps.  I could see the door hanger through the terminal window.  But, when I clicked the terminal window to move it to reveal the door hanger, the door hanger flashed on top for an instant then disappeared.  

Please advise if current behavior is expected, given click anywhere to dismiss.
Status: RESOLVED → VERIFIED
Whiteboard: [qa+] → [qa!]
(In reply to [:tracy] Tracy Walker - QA Mentor from comment #10)
> Please advise if current behavior is expected, given click anywhere to
> dismiss.

It is currently expected, although bug 966098 exists to come up with something better.
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: