Australis: Far right/left selected overflow tabs look bad on session restore.

VERIFIED FIXED in Firefox 29

Status

()

Firefox
Theme
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Caspy7, Assigned: jaws)

Tracking

(Blocks: 1 bug)

unspecified
Firefox 31
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(firefox29 verified, firefox30 verified, firefox31 verified)

Details

(Whiteboard: [Australis:P3-])

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

3 years ago
Created attachment 8374695 [details]
Tab Overflow

I have several windows with tabs filling up and overflowing the tab bar.  On most windows the far right tab is selected.  After restoring a session, *all* of my windows whose tab rows are full and that have the rightmost tab selected are scrolled ever so slightly off the tab bar - the bottom curve it seems (see attached screenshot).
I tried reproducing this with a different profile (filling several windows with tabs) and ironically could only get the *leftmost* selected tab to trail off the end, like the screenshot, on session restore.

It's obviously not a showstopper, but it's poor polish and for someone like me with that tinge of OCD I have to go through and hit the scroll arrow on all the cases. It just looks bad.

Updated

3 years ago
Blocks: 732583
Whiteboard: [Australis:P3-]

Updated

3 years ago
Duplicate of this bug: 973340
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Hm, I could reproduce this last week but can't anymore. Caspy7, can you still reproduce this on a new nightly build?
Flags: needinfo?(caspy77)
(Reporter)

Comment 3

3 years ago
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #2)
> Hm, I could reproduce this last week but can't anymore. Caspy7, can you
> still reproduce this on a new nightly build?

Still seeing this on the latest nightly.
Flags: needinfo?(caspy77)
Ok, I can reproduce with the left-most selected tab.
I'm pretty sure I've gotten it figured out now. Patch coming soon.
Created attachment 8402890 [details] [diff] [review]
Patch

Kinda stinks to reach in to private methods and properties of mTabstrip, but it's not the first place within tabbrowser.xml.
Attachment #8402890 - Flags: review?(mconley)
Created attachment 8402892 [details] [diff] [review]
Patch v1.01 (forgot to qref)
Attachment #8402890 - Attachment is obsolete: true
Attachment #8402890 - Flags: review?(mconley)
Attachment #8402892 - Flags: review?(mconley)
Comment on attachment 8402892 [details] [diff] [review]
Patch v1.01 (forgot to qref)

I agree on both the gross-ness of sucking out private members of mTabstrip, and also at the sentiment that "we were doing it already, so what the hell."

We really should consider trying to expose those as public read-only members instead. I wouldn't block on it, but can you please file a bug to do that?

Also, have you done a try push to see how this could affect TART? If not, maybe do that. Or not, and take your chances on fx-team / m-c. :)
Attachment #8402892 - Flags: review?(mconley) → review+
Baseline: https://tbpl.mozilla.org/?tree=Try&rev=41633908c8a5
With patch: https://tbpl.mozilla.org/?tree=Try&rev=a4b0bb1a83b9

Compare talos: http://compare-talos.mattn.ca/?oldRevs=41633908c8a5&newRev=a4b0bb1a83b9&server=graphs.mozilla.org&submit=true
Compare-talos shows that there is no TART regression from this patch.

Landed on fx-team: https://hg.mozilla.org/integration/fx-team/rev/6aef8ef7d775
Whiteboard: [Australis:P3-] → [Australis:P3-][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/6aef8ef7d775
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3-][fixed-in-fx-team] → [Australis:P3-]
Target Milestone: --- → Firefox 31
status-firefox29: --- → affected
status-firefox30: --- → affected
status-firefox31: --- → fixed
Comment on attachment 8402892 [details] [diff] [review]
Patch v1.01 (forgot to qref)

[Approval Request Comment]
Bug caused by (feature/regressing bug #): introduction of tab curves missed this case that has to be manually adjusted for the negative margins on tab curves
User impact if declined: session restore can have partial tabs showing (curve is clipped)
Testing completed (on m-c, etc.): on m-c for a few days
Risk to taking this patch (and alternatives if risky): none expected
String or IDL/UUID changes made by this patch: none
Attachment #8402892 - Flags: approval-mozilla-aurora?
Attachment #8402892 - Flags: approval-mozilla-beta?
Attachment #8402892 - Flags: approval-mozilla-beta?
Attachment #8402892 - Flags: approval-mozilla-beta+
Attachment #8402892 - Flags: approval-mozilla-aurora?
Attachment #8402892 - Flags: approval-mozilla-aurora+
Aurora: https://hg.mozilla.org/releases/mozilla-aurora/rev/2200d43e5485


Beta: https://hg.mozilla.org/releases/mozilla-beta/rev/9798420b26fc
status-firefox29: affected → fixed
status-firefox30: affected → fixed
Caspy7, can you try and see if this works now for you with the builds below?
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/29.0b8-candidates/build1/
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-aurora/
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/
Flags: needinfo?(caspy77)
(Reporter)

Comment 15

3 years ago
I tested with all builds and the problem appears resolved in all of them.
Flags: needinfo?(caspy77)
Status: RESOLVED → VERIFIED
status-firefox29: fixed → verified
status-firefox30: fixed → verified
status-firefox31: fixed → verified
You need to log in before you can comment on or make changes to this bug.