If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

No audio in mono html5 audio on Audio drivers with vendor enhancements.

VERIFIED FIXED in Firefox 28, Firefox OS v1.3

Status

()

Core
Audio/Video
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Danial Horton, Assigned: padenot)

Tracking

Trunk
mozilla30
All
Windows 7
Points:
---

Firefox Tracking Flags

(firefox28 verified, firefox29 verified, firefox30 verified, b2g-v1.3 fixed, b2g-v1.3T fixed, b2g-v1.4 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20140127194636

Steps to reproduce:

Following changeset 168228 / Pushlog 957ddf01db26, the assert reported in Bug 970147 no longer occurs, however instead of a crash there is simply no audio

Paul's code commentation indicates the code should determine the correct behavior further on and since it doesn't i assumed it would be followed up in that existing bug - instead it was closed as fixed (wouldn't consider no sound as being fixed....)


Actual results:

Opening http://flim.org/~kinetik/tests/bug970147/bug970147.mp4 on an XFI or other recent Soundblaster device will result in no sound,

Ticking "Disable Soundblaster Enhancements" in the speaker device properties will allow sound to work


Expected results:

The sound should work regardless of whether the vendor enhancements are enabled or not,  no other playback utility crashes or fails to playback mono aac content because of this setting (and flash currently uses WASAPI itself)

Matthew provided test links for an affected file in the original bug, so here they are
Original: http://flim.org/~kinetik/tests/bug970147/bug970147.mp4
Remuxed:  http://flim.org/~kinetik/tests/bug970147/bug970147_stereo.mp4

As specified before, the remuxed file works, as does the original as long as vendor enhancements are disabled.
(Reporter)

Updated

4 years ago
Hardware: x86_64 → All
Version: 30 Branch → Trunk
(Assignee)

Updated

4 years ago
Assignee: nobody → paul
(Assignee)

Comment 1

4 years ago
Danial, I got a sound card that should be affected [1], and I can't repro. Should I update the drivers ?

Specifically, I did the following:
- Get the CD and install the driver
- Plug the card
- Opened the test case (I could hear sound)
- Fiddled with the soundblaster option thingy
- Retried the test case, it still work (but there is a weird reverb)

[1]: http://www.amazon.fr/dp/B003RRY3WE/ref=pe_386181_37038081_TE_dp_1
(Assignee)

Updated

4 years ago
Flags: needinfo?(danialhorton)
(Reporter)

Comment 2

4 years ago
I'm using the drivers here

http://support.creative.com/downloads/download.aspx?nDownloadId=12715

and im in Game mode and set to 5.1 with 24bit 48khz output.

The issue only occurs if a multichannel speaker mode is set. with that driver

Sorry i had not realised that would effect the repro before hand.
Flags: needinfo?(danialhorton)
(Assignee)

Comment 3

4 years ago
Yeah, so, of course the sound card I ordered does not have CMSS 3D. I sent it back and ordered a new one to debug this.
(Reporter)

Comment 4

4 years ago
Which did you get?

Its not not necessary to obtain exactly the same XFI as me, it should occur on any of the XFI models that use a EMU20k1 or EMU20k2. (The XFI Xtreme Audio is not a true XFI product)

http://en.wikipedia.org/wiki/Sound_Blaster_X-Fi#Products_in_the_XFI_Family

Soundblaster Z was also reported as affected, this uses SBX which seems to be the next evolution of CMSS3D.
I also had this problem reported when playing mono bird songs on xeno-canto.org. I can't find the bugzilla bug where it was reported, but the initial complaint is in their forums:
http://www.xeno-canto.org/discuss_forum.php?topic_nr=7027
(Reporter)

Comment 6

4 years ago
Chris, this issue is specifically related to a fix introduced by Paul on trunk, its unlikely to be related to that issue from september last year when we were still on firefox <27
(Assignee)

Comment 7

4 years ago
I now have a SoundBlaster X-Fi Go! Pro, and I can't figure out how to enable CMSS-3D on it. Amazon says it can be done, but I'm not sure. I'll send it back and ordered an new one, although it's not USB, so I'll have to buy a desktop machine, which might take some time.
(Reporter)

Comment 8

4 years ago
with Volume Panel installed, right click the icon in the tray and select CMSS3D.
(Reporter)

Comment 9

4 years ago
There isn't any need to actually enable CMSS3D anyway, i don't have it enabled and so long as the output is 5.1 no sound is output so long as "Disable SoundBlaster Enhancements" (in windows speaker properties) is not checked.
(Reporter)

Comment 10

4 years ago
I can confirm this usb XFI has cmss3D for sure

http://us.outletstore.creative.com/Refurbished-Sound-Blaster-XFi-Surround-5.1/M/B003P5IAFY.htm
(Reporter)

Comment 11

4 years ago
hadn't noticed that was out of stock

this one which seems based on the Z or Recon series should be affected

http://us.store.creative.com/Creative-Sound-Blaster-XFi-Surround-5.1/M/B0044DEDCA.htm

just needs to be a soundblaster device that can bet set to 5.1 i think.
(Assignee)

Comment 12

4 years ago
Yeah, I'll try with the one I got, and buy this one if it does not work.

I'll also try with my setup at home (10in/10out musician card), but I'm pretty sure it worked there, since it's what I used to write the multichannel handling code.
(Reporter)

Comment 13

4 years ago
is that an EMU or M-audio card?

not all sound drivers include enhancements,  i know the driver for the SoundMax integrated on my motherboard did not include one unless the bundled XFI MB software was installed.
(Assignee)

Comment 14

4 years ago
It's another Creative SoundBlaster, not sure which one.

Comment 15

4 years ago
(In reply to Paul Adenot (:padenot) from comment #12)
> Yeah, I'll try with the one I got, and buy this one if it does not work.
> 
> I'll also try with my setup at home (10in/10out musician card), but I'm
> pretty sure it worked there, since it's what I used to write the
> multichannel handling code.

I am afraid that the card you had already bought a couple of posts above has no CMSS functionality. The safe bet is to find one X-Fi *Titanium* card, with the 20EMU2K chip. And try to test on Windows 7 or older preferably, their Windows 8 driver has some issues.

Sources:
* http://us.store.creative.com/Refurbished-Creative-Sound-Blaster-XFi-Titanium/M/B00D62UYRS.htm
* http://www.amazon.com/Refurbished-Sound-Blaster-X-Fi-Titanium/dp/B00D62UYRS
(Assignee)

Comment 16

4 years ago
Okay, I can repro with a Creative SoundBlaster Z I put in my home desktop machine (that of course can't compile Firefox, that would be too easy) :
- If the "Enable Audio Enhancement" box is ticked (the default), I have a crash on build without the patch, and silence otherwise
- If the box is not ticked, I have sound.

This is with a mono audio file, so I'm pretty sure I'm reproducing what the people in this thread are experiencing. I'll write a patch now.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 17

4 years ago
Created attachment 8382144 [details]
fix-wasapi-soundblaster-z

That makes it work. Apparently, when you untick the "Enable Audio Enhancement" box, WASAPI is able to give you a suggestion. When you tick the box, it can't. Since we already have all the code to handle mono -> 6 channels (which is what the Creative SoundBlaster Z supports), this was easy.
Attachment #8382144 - Flags: review?(kinetik)
Comment on attachment 8382144 [details]
fix-wasapi-soundblaster-z

Thanks for investigating this!
Attachment #8382144 - Flags: review?(kinetik) → review+
(Assignee)

Comment 19

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/7a8e0a49b3f6
(Reporter)

Comment 20

4 years ago
Confirmed fixed on XFI using inbound

https://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-win32/1393509910/

nice job Paul, Does this patch replace or land on top of the patch in Bug 970147?

can we get this uplifted to beta and aurora so the fix is included on the next stable version.
https://hg.mozilla.org/mozilla-central/rev/7a8e0a49b3f6
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
(Assignee)

Comment 22

4 years ago
(In reply to Danial Horton from comment #20)
> Confirmed fixed on XFI using inbound
> 
> https://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-
> inbound-win32/1393509910/
> 
> nice job Paul, Does this patch replace or land on top of the patch in Bug
> 970147?
> 
> can we get this uplifted to beta and aurora so the fix is included on the
> next stable version.

It applies on top. I'll ask for approval, now.
(Assignee)

Comment 23

4 years ago
Comment on attachment 8382144 [details]
fix-wasapi-soundblaster-z

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 866675, initial landing of the WASAPI backend.
User impact if declined: no sound when playing mono media with a certain class of sound cards.
Testing completed (on m-c, etc.): bought an affected sound card, manual test, independent confirmation by reporter (that has another affected sound card).
Risk to taking this patch (and alternatives if risky): alternative is to have no audio track when playing some media.
String or IDL/UUID changes made by this patch: none
Attachment #8382144 - Flags: approval-mozilla-beta?
Attachment #8382144 - Flags: approval-mozilla-aurora?
status-firefox28: --- → affected
status-firefox29: --- → affected
status-firefox30: --- → fixed
Attachment #8382144 - Flags: approval-mozilla-beta?
Attachment #8382144 - Flags: approval-mozilla-beta+
Attachment #8382144 - Flags: approval-mozilla-aurora?
Attachment #8382144 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/fe8ae2fb3f9a
https://hg.mozilla.org/releases/mozilla-beta/rev/ec2f45efc7f7
status-firefox28: affected → fixed
status-firefox29: affected → fixed
https://hg.mozilla.org/releases/mozilla-b2g28_v1_3/rev/ec2f45efc7f7
status-b2g-v1.3: --- → fixed
Danial, can you please confirm this is also fixed in the latest Beta and Aurora builds?
Status: RESOLVED → VERIFIED
status-firefox30: fixed → verified
Flags: needinfo?(danialhorton)
(Reporter)

Comment 27

4 years ago
testing on Beta built from https://hg.mozilla.org/releases/mozilla-release/rev/0414e679f2ab (current auto update build)

Result:  Bug 970147 not fixed. (figured it wouldn't be)

Testing on beta tinderbox build https://hg.mozilla.org/releases/mozilla-beta/rev/f988a03ddc6d

Result: both Bug 970147 and this one fixed

Aurora via auto update also working.
Flags: needinfo?(danialhorton)
Thanks for your help, Danial.

The next Beta builds should appear here in a couple hours:
ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/28.0b8-candidates/build1/

If you wouldn't mind double checking this is fixed with them as well.

Thanks
status-firefox28: fixed → verified
status-firefox29: fixed → verified
status-b2g-v1.3T: --- → fixed
status-b2g-v1.4: --- → fixed
You need to log in before you can comment on or make changes to this bug.