Closed Bug 970147 Opened 6 years ago Closed 6 years ago

Crash due to fatal assert in WASAPI: handle_channel_layout asserts with "Format not supported, and no suggestion from WASAPI."

Categories

(Core :: Audio/Video, defect)

All
Windows Vista
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla30
Tracking Status
firefox28 --- verified
firefox29 --- verified
firefox30 --- verified
b2g-v1.3 --- fixed
b2g-v1.3T --- fixed
b2g-v1.4 --- fixed

People

(Reporter: kinetik, Assigned: padenot)

References

Details

(Keywords: crash)

Crash Data

Attachments

(1 file)

This was reported bug Danial Horton in bug 950026 comment 10 onwards:

(In reply to Danial Horton from comment #10)
> I do not believe this is fixed,
> 
> I can crash 26, 27, 28 and 29 by simply  opening
> https://vine.co/v/ManB7AzZjtP
> 
> The issue also occurs with tumblr video's.

(In reply to Danial Horton from comment #11)
> Issue is confirmed NOT resolved with Creative Soundblaster and Realtek
> hardware when vendor specific enhancements are enabled.
> 
> Crash can be reproduced 100% until "Disable [Product name] Enhancements" is
> ticked in Speaker device properties
> 
> I expect the enhancement modules provided with Recon and Z(x/R) series
> soundblaster cards will exhibit the same issue.

(In reply to Danial Horton from comment #12)
> Was this specific to certain html5 players?
> 
> Youtube's works without issue whilst tumblrs and vines just assert
> 
> https://crash-stats.mozilla.com/report/index/84243c37-eb98-44ea-9278-097f32140208
> https://crash-stats.mozilla.com/report/index/da35a63d-c06c-4206-91a5-be4b12140208
> https://crash-stats.mozilla.com/report/index/d83e9d96-e411-43c5-916d-d87d32140208
> https://crash-stats.mozilla.com/report/index/03601244-ce1c-4f0e-ad45-ee1f22140208
> https://crash-stats.mozilla.com/report/index/5b76fb4f-4ed0-4827-a934-005412140208
> https://crash-stats.mozilla.com/report/index/ac8e8f41-020c-49db-8182-b2c6e2140208
> https://crash-stats.mozilla.com/report/index/157893f1-dcef-4c93-aedb-31bf32140208
> https://crash-stats.mozilla.com/report/index/6810e793-a3b8-4095-9678-fd0e22140208
The linked Vine video's audio track is 44.1kHz mono AAC:
      Stream #0:1(und): Audio: aac (mp4a / 0x6134706D), 44100 Hz, mono, fltp, 65 kb/s (default)

Danial, can you please test the following two links and confirm that the former (the original video) crashes and the latter (remuxed to stereo) does not?

Original: http://flim.org/~kinetik/tests/bug970147/bug970147.mp4
Remuxed:  http://flim.org/~kinetik/tests/bug970147/bug970147_stereo.mp4
The remuxed video indeed played without issue.

I can replicate this crash on many other twitter, tumblr and  vine videos, so it seems there is alot of mono html5 videos out there.
Whats interesting is that i literally have none of the XFI enhancements enabled, unchecked all of them.

So i don't know what the disable Soundblaster Enhancements checkbox in Speaker Properties is actually doing (i do know CMSS3D is not possible with this disabled, but i did not have cmss3d enabled either).
Ok, both twitter and tumblr use vine so that explains the coverage (didn't know that previously)

and im guessing all affected video's are mono aac because they are mobile phone uploads.
Assignee: nobody → paul
Duplicate of this bug: 970519
(In reply to Danial Horton from comment #3)
> Whats interesting is that i literally have none of the XFI enhancements
> enabled, unchecked all of them.
> 
> So i don't know what the disable Soundblaster Enhancements checkbox in
> Speaker Properties is actually doing (i do know CMSS3D is not possible with
> this disabled, but i did not have cmss3d enabled either).

These cards (X-Fi Titanium/Soundblaster Z) have some software that tries to map multichannel audio into headphone sound. They do so by setting the Windows environment to a multichannel one, to trick applications into producing a sound stage with as much 3d information as possible.

Then, within the card's software, HRTF mapping converts the multichannel audio to 2-channel headphone audio, that retains a part of the 3d sound staging.
Its called CMSS3D, and its disabled ;)

So I don't really get what the enhancements are enhancing :p
Sound blaster Z does not have cmss3d. 

As for the enhancements, do you have EAX, or Crystalizer enabled?
Recon and SBZ(X/XR) implement SBX Pro Studio which basically does the same with as CMSS3D.

Crystalizer was disabled, and the EAX setting only toggles the effect of EAX when EAX is actually implemented in a game via OAL or Dsound(via OAL)
But thats beyond the point really,  Every other application i use that outputs via WASAPI has no issues with the xfi's enhancements, so its still a bug Firefox.
Crash Signature: [@ abort | abort | _wassert | `anonymous namespace'::handle_channel_layout ]
Crash Signature: [@ abort | abort | _wassert | `anonymous namespace'::handle_channel_layout ] → [@ abort | abort | _wassert ]
Again, we let the rest of the code figure it out instead of asserting.
Attachment #8374489 - Flags: review?(kinetik)
Attachment #8374489 - Flags: review?(kinetik) → review+
tested on tinderbox build 1392166507/ from

https://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-win32/1392166507/

no audio in demonstration url
https://hg.mozilla.org/mozilla-central/rev/957ddf01db26
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
um, wow

do you not listen?
Could someone reopen this, Ryan clearly hasn't got the configuration necessary to test whether or not this is really fixed.
Danial, a bug gets automatically marked as RESOLVED FIXED *by a script* when a patch gets merged to mozilla-central, and the bug is not marked as "leave-open".

This bug was about resolving the crash, can you confirm Firefox does not crash anymore? I'm ordering a sound card at the moment to try to repro myself and really fix this (i.e., properly map the channels), but I'll only be at home next week.
Flags: needinfo?(danialhorton)
Sorry, yeah the crash is resolved, single channel aac content just doesn't output any audio anymore unless Soundblaster enhancements is disabled.

I believe the XFI MB software installs the Soundblaster Enhancements - this might be enough to reproduce the issue, but finding people running this is actually very rare.

http://www.creative.com/oem/products/software/x-fimb.asp

I imagine the newer packages do as well

http://www.creative.com/oem/products/software/x-fimb2.asp
http://www.creative.com/oem/products/software/x-fimb3.asp

Products that are affected are the XFI range based on the Emu20k processors, I am not sure if the Xtreme Audio is, as it is based on a Cmedia processor.
I assume the Recon3D cards as well, since the Soundblaster Z series is affected according to Michail

I'm checking with some hardware sites to see if XFI-MB can trigger the crash presently,
Flags: needinfo?(danialhorton)
Danial filed bug 971693 for the "no sound" issue now that the crash is fixed.
Matthew, Paul, was it perhaps a mistake to close my own bug# 970519? If I understand correctly, bug handling is always very specific to the poster's issue. My own case *is* related but OTOH it regards crashes during Battlefield 4.

Any idea on how should I proceed? Reopen perhaps 970519? Other?
Michail, your crash is caused by battlelog using html5 for some sort of tone or beep.
Might be so; I have not installed Flash, so battlelog plugins might be using HTML5 to produce the sounds? But, OTOH, if that was the case, why did I not experience any issues at all with FF 26?

And in which bug report should I continue to pursue a solution to my issue?
Michail, are you still seeing crashes with a current nightly build? If so, can you please reopen your bug and post a link to a new crash report?  If you're not crashing, but no longer have audio, that's bug 971693.
Keywords: crash
current nightly build  30.0a1 (2014-02-11) fix my crashing with battlefield can we get this fix in the 27 build.
it is unlikely to reach Fx27
(In reply to Matthew Gregan [:kinetik] from comment #23)
> Michail, are you still seeing crashes with a current nightly build? If so,
> can you please reopen your bug and post a link to a new crash report?  If
> you're not crashing, but no longer have audio, that's bug 971693.

Matthew please accept my apologies, I was not tracking this bug, when I saw your post. I'd like to test it a nightly, but:
(a) is it safe to use, considering that I am using it along with firefox sync for production?
(b) where do I download it from? I assume I uninstall old FF, install nightly or something?

Or can I just wait for a released FF to try if it fixes things?
(In reply to Michail Pappas from comment #26)
> Matthew please accept my apologies, I was not tracking this bug, when I saw
> your post. I'd like to test it a nightly, but:

No problem!  Thank you for offering to test.

> (a) is it safe to use, considering that I am using it along with firefox
> sync for production?
> (b) where do I download it from? I assume I uninstall old FF, install
> nightly or something?

You can install and run a nightly build and your regular Firefox install side by side safely.  No need to uninstall your existing Firefox install.  By default they will use the same profile, so you can only run one at a time.  To be extra safe, I'd recommend creating a new profile to run the nightly build against, that way there is no chance that anything could happen to your existing Firefox profile/sync/etc.  Instructions for setting up and running against a separate profile are here: https://developer.mozilla.org/en-US/docs/Mozilla/Multiple_Firefox_Profiles#Windows
is there a way to make Firefox  Nightly to update new builds without downloading them manually.
was on 30.0a1 (2014-02-11)byt i had to download the new files and install 30.0a1 (2014-02-24)
(In reply to d_lomond from comment #28)
> is there a way to make Firefox  Nightly to update new builds without
> downloading them manually.
> was on 30.0a1 (2014-02-11)byt i had to download the new files and install
> 30.0a1 (2014-02-24)

It will update automatically. You can also check if there is a new version by pressing ALT (to make the menu show up), Help, About. Here, it will prompt for download and installation.
(In reply to Matthew Gregan [:kinetik] from comment #23)
> Michail, are you still seeing crashes with a current nightly build? If so,
> can you please reopen your bug and post a link to a new crash report?  If
> you're not crashing, but no longer have audio, that's bug 971693.

Using nightly 30.0a1 (2014-02-25), the issue is not reproducible at all, good job!
can we get this fix in the version 28
fix is not complete, so probably not.
Comment on attachment 8374489 [details] [diff] [review]
Don't assume WASAPI can give us a channel layout suggestion. r=

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 866675, initial landing of the WASAPI backend.
User impact if declined: crash when playing mono media with a certain class of sound cards.
Testing completed (on m-c, etc.): bought an affected sound card, manual test, independent confirmation by reporter (that has another affected sound card), that the crash does not occur anymore.
Risk to taking this patch (and alternatives if risky): crash on an assert.
String or IDL/UUID changes made by this patch: none.
Attachment #8374489 - Flags: approval-mozilla-beta?
Attachment #8374489 - Flags: approval-mozilla-aurora?
Attachment #8374489 - Flags: approval-mozilla-beta?
Attachment #8374489 - Flags: approval-mozilla-beta+
Attachment #8374489 - Flags: approval-mozilla-aurora?
Attachment #8374489 - Flags: approval-mozilla-aurora+
Danial, can you please confirm these crashes are gone for you now with the latest Beta, Aurora, and Nightly builds?
Flags: needinfo?(danialhorton)
testing on Beta built from https://hg.mozilla.org/releases/mozilla-release/rev/0414e679f2ab (current auto update build)

Result:  Bug 970147 not fixed. (figured it wouldn't be)

Testing on beta tinderbox build https://hg.mozilla.org/releases/mozilla-beta/rev/f988a03ddc6d

Result: Fixed.

Aurora via auto update also working.
Flags: needinfo?(danialhorton)
Thanks for your help, Danial.
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #38)
> Thanks for your help, Danial.

The next Beta builds should appear here in a couple hours:
ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/28.0b8-candidates/build1/

If you wouldn't mind double checking this is fixed with them as well.

Thanks
This was a problem for me on Vine, Comcast voicemail, some YouTube, and several other sites. I can confirm that the latest build resolves the crash and the sound plays. HOWEVER, the sound plays only from the front LEFT speaker, which is wrong and isn't how it worked before the bug was introduced.
Its mono audio, so outputting to the left speaker is somewhat expected behavior - most players use stereo expansion on mono content though.
I checked Firefox 24.3 ESR and mono sound sources play through the front left, center, and front right speakers. Are you saying it's by design and desired that now they play only through the left? It seems like a regression. I'd expect that behavior only for a stereo audio source that only has left channel data.
(In reply to vtqobex from comment #42)
> I checked Firefox 24.3 ESR and mono sound sources play through the front
> left, center, and front right speakers. Are you saying it's by design and
> desired that now they play only through the left? It seems like a
> regression. I'd expect that behavior only for a stereo audio source that
> only has left channel data.

I don't think that's intentional, so yes I'd call it a regression.  Would you mind filing a new bug and CCing Paul Adenot and myself please?
Bug 979705.
Strangely enough, i am still crashing on any sound "originating" from HTML 5.
what audio hardware and drivers do you have.
(In reply to Rag from comment #45)
> Strangely enough, i am still crashing on any sound "originating" from HTML 5.

It's probably worth reporting a new bug for this so it can be investigated. The particular trigger here has been verified fixed. Note, when filing a new bug we'll need to know your exact steps to reproduce, including source URLs, hardware (sound card in particular), platform, and links to any crash reports from about:crashes.

Thanks
(In reply to Danial Horton from comment #46)
> what audio hardware and drivers do you have.

Creative Sound Blaster X-Fi Titanium with its 2.40.0008 driver

(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #47)
> (In reply to Rag from comment #45)
> > Strangely enough, i am still crashing on any sound "originating" from HTML 5.
> 
> It's probably worth reporting a new bug for this so it can be investigated.
> The particular trigger here has been verified fixed. Note, when filing a new
> bug we'll need to know your exact steps to reproduce, including source URLs,
> hardware (sound card in particular), platform, and links to any crash
> reports from about:crashes.
> 
> Thanks

Things like the audio player on Wikipedia, vines, and http://www.chatzy.com/ if i click on alert, HTML 5 sound alert and Test now, Firefox crashes.
The test button crash can be reproduced in Firefox 27.01 and has the same crash cause as this bug
https://crash-stats.mozilla.com/report/index/ef363c50-60ac-4635-b33b-09f7a2140319

I cannot reproduce the issue in Current Beta, Nightly or Aurora builds.

The crash scenario perfectly aligns with this bug, however, it is definitely fixed in Firefox 28 and higher using Windows 7(WASAPI).
Please update to 28, it went live in the last 24 hours.
(In reply to Danial Horton from comment #51)
> Please update to 28, it went live in the last 24 hours.

Indeed, i had to update manually for some reason. The bug is fixed, thanks a Lot.
(In reply to Rag from comment #52)
> (In reply to Danial Horton from comment #51)
> > Please update to 28, it went live in the last 24 hours.
> 
> Indeed, i had to update manually for some reason. The bug is fixed, thanks a
> Lot.

Thank you for confirming. If you see a similar issue in the future please report a new bug.
You need to log in before you can comment on or make changes to this bug.