Closed Bug 971713 Opened 6 years ago Closed 6 years ago

Device name field in Preferences should be inline

Categories

(Firefox :: Sync, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 --- verified
firefox30 --- verified

People

(Reporter: rfeeley, Assigned: mak)

References

Details

(Whiteboard: p=1 s=it-30c-29a-28b.2 [qa!])

Attachments

(1 file)

Much like the Home Page field in the General pane of Preferences, the device name field in Preferences should be inline (beside the label, and not beneath it).

CURRENT:
https://www.dropbox.com/s/65meiq8b93vcxi8/device-name-current.png

PROPOSED:
https://www.dropbox.com/s/jcoae4x4m3l02nc/device-name-proposed.png
OS: Mac OS X → All
Hardware: x86 → All
Whiteboard: p=0
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Whiteboard: p=0 → p=1 s=it-30c-29a-28b.2
QA Contact: twalker
Whiteboard: p=1 s=it-30c-29a-28b.2 → p=1 s=it-30c-29a-28b.2 [qa+]
Attached patch patch v1Splinter Review
I looked for in-content preferences, then I found bug 967674, I'm adding that to the backlog since sounds like something that should be addressed soon.
Attachment #8380001 - Flags: review?(ttaubert)
Attachment #8380001 - Flags: review?(ttaubert) → review+
https://hg.mozilla.org/integration/fx-team/rev/053ed9efd81b
Target Milestone: --- → Firefox 30
Time, should these Sync ui bugs be uplifted?
Flags: needinfo?(ttaubert)
Yes, please request Aurora approval.
Flags: needinfo?(ttaubert)
https://hg.mozilla.org/mozilla-central/rev/053ed9efd81b
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Comment on attachment 8380001 [details] [diff] [review]
patch v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): no regression
User impact if declined: sync UI looks bad
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): trivial patch, no risk
String or IDL/UUID changes made by this patch: none
Attachment #8380001 - Flags: approval-mozilla-aurora?
Attachment #8380001 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Hi Tracy, can you provide an update on when testing of this bug will be completed for verification?
Flags: needinfo?(twalker)
Verified on both Nightly and Aurora.

I'll be testing and verifying fixes from this week today. Then again Monday for anything fixed today and over the weekend.
Status: RESOLVED → VERIFIED
Flags: needinfo?(twalker)
Whiteboard: p=1 s=it-30c-29a-28b.2 [qa+] → p=1 s=it-30c-29a-28b.2 [qa!]
Great, thanks for the update Tracy.
No longer blocks: fxdesktopbacklog
Flags: firefox-backlog+
You need to log in before you can comment on or make changes to this bug.