Closed Bug 97186 Opened 19 years ago Closed 11 years ago

Method of having alphabetical sort for newsgroups in the folder pane.

Categories

(MailNews Core :: Backend, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: stephend, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Build ID:  2001-08-27-03, All OSs.

Summary:  Method of having alphabetical sort for newsgroups.

When the newsgroup listings were fixed to use the RC file's order, the
alphabetical sorting capability was lost (albeit you can still hand-edit the RC
file)

Comments from Chris Palmer:

How about an alpha sort / no sort toggle on the button where you decide to
show number read or unread columns?  Or click on the header bar above the
newsgroup name column?
QA Contact: esther → stephend
Summary: Method of having alphabetical sort for newsgroups. → Method of having alphabetical sort for newsgroups in the folder pane.
I think is is important.  Had I not read the bug just now and found you could
edit the RC file... this would really **** me off.  It's really annoying when
you add a new newsgroup in in comp.* and it appears after all your sci.* groups.

One step up from this would be an arbitrary ordering.
Would it be possible to sort them hierarchically, as they are in the subscribe
dialog? It would also be nice if you could hide the server, so if you have
several news servers you can see all groups from all servers under the category
"news".
*** Bug 148605 has been marked as a duplicate of this bug. ***
Has anyone had any luck with this RFE?  It's a minor thing, but one of those
that needs to be done to make Mozilla appear to have a 'smooth', intelligent
interface.
as posted to the wishlist newsgroup
current CVS has sorted my newsgroup listing alphabetically.

So is this effectively fixed ?

[it hasn't re-ordered next-newsgroup by pressing "space" but
that's another problem]
*** Bug 191290 has been marked as a duplicate of this bug. ***
Nigthly Mozilla 1.3b, Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b)
Gecko/20030130 does not sort anything ...
It would be good having a default setting that all newsgroups in the pane are
sorted, no matter which order is used in the rc file.
*** Bug 200915 has been marked as a duplicate of this bug. ***
*** Bug 208926 has been marked as a duplicate of this bug. ***
Depends on: 150274
This should really be done by 1.5 lately ... 
It is a pain to manually sort the rc file.  Can someone give an update on where
this enhancement stands?

Dan
Feature creep: It would be nice if there was an option to sort newsgroups, as
well as arrange newsgroups manually using drag and drop. Hierarchically sorted
is not necessarily the preferred option.
*** Bug 245030 has been marked as a duplicate of this bug. ***
I suggest as a simple start to sort all ng entries after some new ones were
subscribed, then save this new order to the newsrc file and display it in the
MailNews window.
Does this bug also apply to Thunderbird?  Should it be re-filed for Thunderbird?
Product: Browser → Seamonkey
Assignee: sspitzer → mail
Any action on this recently?
(In reply to comment #17)
> Any action on this recently?

This is your second comment in this bug and both are pretty useless. If someone
would be working on this feature, (s)he would have taken the bug and/or posted a
patch. Please make only comments that help (eg. post a patch yourself or point
to a relevant extension or something like that).

That said, sorry for spamming.
Here are some very related bugs...perhaps the people involved could consolidate
on this?

Bugzilla Bug 61078 - Ability to Change Order of Accounts
Bugzilla Bug 97186 - Method of having alphabetical sort for newsgroups in the
folder pane.
Bugzilla Bug 150274 - User should be able to reorder the Newsgroups like in NS4
This bug does appear to ask for a subset of the same capabilities as 150274, so
I suggest marking this one as a duplicate.  Changing the order of accounts,
however, is an unrelated problem.
I agree with jdg@diogenes.sacramento.ca.us, this is a dupe for 150274.
Originally the lack of newsgroup sorting in Mozilla/Seamonkey/Thunderbird builds
seems to be  regression from the old NS4 days ...

Recommendation: mark as dupe for 150274
(In reply to comment #21)
> I agree with jdg@diogenes.sacramento.ca.us, this is a dupe for 150274.
> Originally the lack of newsgroup sorting in Mozilla/Seamonkey/Thunderbird builds
> seems to be  regression from the old NS4 days ...
> 
> Recommendation: mark as dupe for 150274

No, if anything, bug 150274 would be a DUP of this.
Assignee: mail → nobody
Component: MailNews: Main Mail Window → MailNews: Backend
Product: Mozilla Application Suite → Core
QA Contact: stephend → backend
With bug 150274 now fixed, this is WONTFIX, no? Or FIXED, depending how you look at it:)
Product: Core → MailNews Core
FIXED it is.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.