Touch UI Start Tiles not clickable

RESOLVED INCOMPLETE

Status

defect
RESOLVED INCOMPLETE
5 years ago
2 years ago

People

(Reporter: mastacheata, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: p=3)

Reporter

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20140127194636

Steps to reproduce:

Open Firefox 28 Beta in Windows 8 Touch mode and start a new tab.
The "start screen" lists some bookmarks, most and recently visited sites.
Now try to click one of these tiles using the touch input.

I've tried this using my Lenovo Thinkpad Helix in "Tablet only" mode without having the keyboard/docking station part of the hybrid attached.
The situation doesn't change if using the digitizer/pen input instead of the "finger-touch" input.


Actual results:

Nothing. The sites don't open, no error message appears, not the smallest sign that anything occurs at all.

When long-pressing, you can mark tiles and potentially remove them from the start screen, but that's not what I'm looking for


Expected results:

I would've expected the clicked/touched tile to open the corresponding website in the current tab, replacing the "start screen"
Component: Untriaged → General
OS: Windows 7 → Windows 8
Version: 28 Branch → unspecified
Product: Firefox → Firefox for Metro
Reporter

Updated

5 years ago
OS: Windows 8 → Windows 8.1
Reporter

Comment 1

5 years ago
Just updated to FF28b3, but no change, the tiles still don't work.
I also just tried if this might be related to the touch input vs. keyboard/mouse input, but that didn't make a difference either.

Also: The computer from which I reported the issue is quite obviously not the same as the one that HAS the problem, so any of the UA and Build ID mentioned in the auto-created first comment should be irrelevant.

Updated

5 years ago
Whiteboard: [triage]

Updated

5 years ago
Component: General → Firefox Start
Assignee: nobody → ally
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P1
QA Contact: kamiljoz
Whiteboard: [triage] → p=0 s=it-30c-29a-28b.3 r=ff30
Whiteboard: p=0 s=it-30c-29a-28b.3 r=ff30 → p=3 s=it-30c-29a-28b.3 r=ff30
Can you try this on Nightly or Aurora (30 & 29 respectively?) I'm not seeing this on today's Nightly build. It would help me narrow down if this is just a beta only bug or something else.


Thanks!
Flags: needinfo?(mastacheata)
Went through the following test cases for all the builds listed below:

- Ensured that you can tap on tiles under "Top Sites, Bookmarks and Recent History" (scrolled to different positions and ensured tiles were still working)
- Ensured that the tiles under all the categories can be taped on when opening a new tab via the overlay button and the "+" under the Navigation App Bar
- Created a bunch of "Recent History" and "Bookmarks" and ensured that all the tiles were still working
- Ensured that the tiles that have been created because under fxdesktop websites are working correctly when switching into fxmetro
- Went through all of the above test cases using several different variations of snapped view

Builds used:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/28.0b1/ (couldn't reproduce issue)
- http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/28.0b2/ (couldn't reproduce issue)
- http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/28.0b3/ (couldn't reproduce issue)
- http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/28.0b4/ (couldn't reproduce issue)
- http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/28.0b6/ (couldn't reproduce issue)
- http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/28.0b7/ (couldn't reproduce issue)
- http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/28.0b8/ (couldn't reproduce issue)
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-03-04-03-02-04-mozilla-central/ (couldn't reproduce issue)
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-03-04-00-40-03-mozilla-aurora/ (couldn't reproduce issue)

I don't think this is a wide spread issue or we would definitely be hearing about it by now. Tiles that are not working would be very noticeable.

mastacheata, are you receiving this issue on all your touch based machines/devices? Would you be able to download a BETA directly from one of the links above and see if it's still occurring? I couldn't reproduce the problem with my Surface Pro 2.
Reporter

Comment 4

5 years ago
> mastacheata, are you receiving this issue on all your touch based machines/devices?
I only have this single touch-based PC-compatible device. (Of course I've got a Smartphone and my dad's got an iPad, but neither of these is going to help here)
I also don't know anyone else with a PC-based touch-device where I could try this.

> Would you be able to download a BETA directly from one of the links above and see if it's still occurring? 
I can still reproduce the issue with the beta releases. The nightly builds work fine now. (The last time I tried this on Aurora a couple of weeks before I opened this bug, the problem existed in Aurora as well)
Flags: needinfo?(mastacheata)
mastacheata, are you using any addons when you're switching into Firefox Metro?
Flags: needinfo?(mastacheata)
Reporter

Comment 6

5 years ago
Do you mean if I have any Addons installed and active or if there are any Addons specific to the Metro UI?
I have quite a few addons installed and active.

This is the list of installed addons copied from Help => Information for Troubleshooting
(this might not actually be the correct term as I just freely translated this from german)
> Adblock Plus	2.5.1	true	{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
> Barlesque	1.15	true	barlesque@dmitriy.khudorozhkov
> Firebug	1.12.6	true	firebug@software.joehewitt.com
> FirePHP	0.7.4	true	FirePHPExtension-Build@firephp.org
> Fox To Phone	1.2.4	true	sendtophone@martinezdelizarrondo.com
> Greasemonkey	1.15	true	{e4a8a97b-f2ed-450b-b12d-ee082ba24781}
> JS Deminifier	1.0.9	true	jsdeminifier@murphy.ben.name
> JSONView	0.7	true	jsonview@brh.numbera.com
> LastPass	2.0.20	true	support@lastpass.com
> Link Location Bar	1.1.4	true	linklocationbar@gnt.de
> NoScript	2.6.8.16	true	{73a6fe31-595d-460b-a920-fcc0f8843232}
> Official My JDownloader Add-On	1.316	true	jid1-OY8Xu5BsKZQa6A@jetpack
> ProxMate - Proxy on steroids!	2.3.3	true	jid1-QpHD8URtZWJC2A@jetpack
> Quick Locale Switcher	1.7.8.5	true	{25A1388B-6B18-46c3-BEBA-A81915D0DE8F}
> ReloadEvery	17.0.0	true	{888d99e7-e8b5-46a3-851e-1ec45da1e644}
> Restartless Restart	9	true	restartless.restart@erikvold.com
> RESTClient	2.0.3	true	{ad0d925d-88f8-47f1-85ea-8463569e756e}
> SearchLoad - Einstellungen	0.7.4	true	searchloadoptions@esteban.torres
> SynoLoader	0.20	true	lemutar@gmail.com
> User Agent Switcher	0.7.3	true	{e968fc70-8f95-4ab9-9e79-304de2a71ee1}
> Xmarks	4.2.5	true	foxmarks@kei.com

Let me know if you need more info or if I should try anything else.
Flags: needinfo?(mastacheata)
Yup, I just meant if you have any addons that are installed and active and not specific to the Metro UI.

This could possibly be another instance of Bug #976849. Once it lands on BETA, would you mind checking to see if that has fixed your problem?

Thanks again for posting this and replying back with all the needed information!
Reporter

Comment 8

5 years ago
Sure, I'll keep an eye on it.
The problem descriptions looks pretty much exactly like what I had noticed.
I think Kamil's hypothesis has merit. 

I can't reproduce this on any of the machines available to me, so I have to drop this bug. 

mastsacheata, if you see this behavior after bug 876849 lands, NEEDINFO kamil or myself to get it back on our radar.

Thanks so much for reporting and your patience.
Assignee: ally → nobody
Status: ASSIGNED → NEW
Priority: P1 → --
QA Contact: kamiljoz
Whiteboard: p=3 s=it-30c-29a-28b.3 r=ff30 → p=3
Mass close of bugs in obsolete product https://bugzilla.mozilla.org/show_bug.cgi?id=1350354
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.