taping inside empty URL bar places a monocle at the top left corner

VERIFIED FIXED in Firefox 30

Status

defect
P2
normal
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: kjozwiak, Assigned: azasypkin)

Tracking

unspecified
Firefox 30
x86
Windows 8.1
Dependency tree / graph

Firefox Tracking Flags

(firefox28 unaffected, firefox29- affected, firefox30 unaffected)

Details

(Whiteboard: p=2 s=it-30c-29a-28b.2 r=ff30)

Attachments

(1 attachment, 1 obsolete attachment)

When you tap on the URL search bar under the Navigation App Bar, you'll notice that a monocle is being placed at the top left corner of the screen. I've reproduced this with Nightly/Aurora but couldn't reproduce the issue with the latest BETA (builds listed below)

- Attached a screenshot to illustrate the issue

Steps to reproduce the issue:

1) Open fxmetro
2) Under the about:start page, tap the URL search bar under the "Navigation App Bar"
3) The OSK should slide in and you should see a monocle appearing at the top left corner of the screen

You might have to repeat Step #2 & Step #3 a few times (I usually get it the second time around)

Current Behavior:

- Taping on the empty URL search bar under the Navigation App Bar creates a monocle that's being placed at the top left corner of the screen

Expected Behavior:

- Monocle shouldn't be placed at the top left corner of the screen. Also, if there's no text available under the URL Search Bar, the monocle shouldn't be displayed as there's no text to select.

Used the following builds to reproduce the issue:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-02-12-00-40-02-mozilla-aurora/
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-02-12-03-02-01-mozilla-central/
Attached the wrong screenshot previously, attached the correct one and set the other one as obsolete.
Attachment #8375003 - Attachment is obsolete: true
Assignee: nobody → azasypkin
Status: NEW → ASSIGNED
Hi Kamil, I was able to reproduce it on the build you mentioned, but can't reproduce on the latest sources. Looks like it was fixed in the scope of bug 957646 indirectly.

Can you please check it on the latest build once it's available?
I was able to reproduce on mc / week old checkout. But I can't reproduce on a checkout from this morning.

However, apparently this is on aurora, in which case we need to figure out which mc patches fixed this and get them uplifted.
No longer blocks: metrov1backlog
Whiteboard: [triage] [defect] p=0 → [defect] p=0
I went through the issue again with all the latest builds and could only reproduce the problem on Aurora. It looks like it's not happening on Nightly with today's build, BETA is still working without any issues.

Used the following builds:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-02-13-03-02-01-mozilla-central/ <- Couldn't reproduce the issue
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-02-13-00-40-02-mozilla-aurora/ <- Reproduced the issue from comment #0 right away
- http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/latest-beta/win32/en-US/ <- Couldn't reproduce the issue
Great, thanks. I'll figure out patch\-es that fixed the issue and we uplift it to Aurora then.
Confirming that it was fixed by patch for bug 957646, but it probably won't be uplifted to Aurora due to regression (bug 972428) at least until we fix regression.
QA Contact: kamiljoz
Whiteboard: [defect] p=0 → p=0 s=it-30c-29a-28b.2 r=ff30
Whiteboard: p=0 s=it-30c-29a-28b.2 r=ff30 → p=2 s=it-30c-29a-28b.2 r=ff30
Priority: -- → P2
Related bugs (including regression bug 972428) were closed and verified, so it looks like we can close this one too.
Depends on: 972428, 957646
For testing and verification.  Reopen if any defects found.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Flags: needinfo?(kamiljoz)
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
Quick Update:

This is still an issue with the latest Aurora build:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-02-24-00-40-03-mozilla-aurora/

Bug #957646 & Bug #972428 need to be uplifted into Aurora for this issue to be fixed. Waiting for those patches to either get uplifted or ride the train to Aurora before marking this as verified.

Leaving needinfo so I can keep an eye on this.
I'm going to close this and mark it as verified. As stated in comment #9, this has been fixed in Nightly and works without any issues. Went through some test cases including the original from comment #0 without any issues.
Status: RESOLVED → VERIFIED
Flags: needinfo?(kamiljoz)
This does not need to be tracked for fx29 anymore since metro project was cancelled.
no longer blocking release as per comment 11
You need to log in before you can comment on or make changes to this bug.