Commit Access (Level 1) for Andrew Overholt

VERIFIED FIXED

Status

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: overholt, Unassigned)

Tracking

Details

Attachments

(1 attachment)

412 bytes, application/vnd.ms-publisher
Details
(Reporter)

Description

5 years ago
Created attachment 8375065 [details]
id_rsa.pub

I'd like to use overholt@mozilla.com as my login name.  SSH public key attached.

I've printed out and scanned a copy of the committer agreement and I'll email it to Shannon.

Comment 1

5 years ago
vouch=me
Adding Shannon for the form.
Flags: needinfo?(sarmitage)
I have received the form.
Flags: needinfo?(sarmitage)
Over to server-ops for hg/scm_level1 bits.
Assignee: mozillamarcia.knous → server-ops

Comment 5

5 years ago
Andrew, I can't make your username with the email alias.  
aoverholt@mozilla.com is your username.

LDAP and ssh_key already in place.

+scm_level_1
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 6

5 years ago
(In reply to comment #5)
> Andrew, I can't make your username with the email alias.  
> aoverholt@mozilla.com is your username.

FWIW this is the user name which goes into ~/.ssh/config.  You can adjust your local hg/git user name to whatever you want.
(Reporter)

Comment 7

5 years ago
Hmm, I can't push to try and I can't ssh to hg.m.o (I realize I won't get a shell):

$ ssh hg.mozilla.org
Could not chdir to home directory : No such file or directory
You do not have a valid mercurial account!
Connection to hg.mozilla.org closed.

I have this in ~/.ssh/config:

Host hg.mozilla.org
 User aoverholt@mozilla.com
 IdentityFile ~/.ssh/id_rsa

I really hope this isn't PEBCAK :)
Status: RESOLVED → REOPENED
Flags: needinfo?(rbryce)
Resolution: FIXED → ---
Andrew I have some very VERY unfortunate news =(

This is indeed a PEBCAK, please see https://developer.mozilla.org/en-US/docs/Mercurial_FAQ

You can't directly ssh into the server BUT there was indeed something missing on our end.
Seems the HG bits weren't enabled but are enabled now. So the instructions in the FAQ should work as expected.

I personally blame Murphy!
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Flags: needinfo?(rbryce)
Resolution: --- → FIXED
(Reporter)

Comment 9

5 years ago
Thanks, Adrian.  I didn't expect to get a shell but was trying to eliminate any key issues.  It seems like we're all good now, as I am able to push to try.  Thanks!
eggcellent, thanks!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.