[e10s] In Gmail and etherpad editor, ⌘B shortcut opens Bookmarks sidebar instead of bolding text

RESOLVED DUPLICATE of bug 862519

Status

()

Core
Keyboard: Navigation
RESOLVED DUPLICATE of bug 862519
4 years ago
4 years ago

People

(Reporter: cpeterson, Unassigned)

Tracking

unspecified
x86
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox30 affected)

Details

(Reporter)

Description

4 years ago
STR:
1. Open new e10s window 
2. Open an etherpad
3. Highlight some text
4. Type ⌘B keyboard short

RESULT:
Bookmarks sidebar opens instead of bolding highlighted text.
(Reporter)

Updated

4 years ago
Component: General → Keyboard: Navigation
(Reporter)

Comment 1

4 years ago
I'm using OS X.
Blocks: 963359
What you're describing is actually the correct behavior.  Content should NOT be able to
hijack chrome keyboard commands such as CTRL/CMD+B.  We have an old bug on that somewhere.
Good to know e10s will finally fix it.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

4 years ago
Really? This bug also breaks Gmail's email composer. These keyboard shortcuts work in Chrome and non-e10s Firefox. Users will be very unhappy when Gmail breaks!

Here is e10s Firefox's new Gmail user experience:

Shortcut    Chrome          Non-e10s Firefox    e10s Firefox
--------    ------          ----------------    ------------
CMD+B       Bold text       Bold text           Open Bookmarks pane!
CMD+I       Italicize text  Italicize text      Open Page Info window!
CMD+U       Underline text  Underline text      Open View Source window!
Summary: [e10s] In etherpad editor, ⌘B shortcut opens Bookmarks sidebar instead of bolding text → [e10s] In Gmail and etherpad editor, ⌘B shortcut opens Bookmarks sidebar instead of bolding text
Yes, really.  Allowing web pages to hijack arbitrary UA commands shouldn't have been
allowed in the first place.  In most cases it's benign or even beneficial like the
ones you mention, but they can also be used to confuse the user for more nefarious
purposes.

Is Gmail.com using contenteditable=true or document.designMode for their composer
input?  If so, we might want to white-list the commands you mention for that
specific use case, or even better to help standardize them.
Olli/Ehsan do you know about any efforts to standardize keyboard commands for
"rich-text editing" elements? (e.g. CMD+B for "make selected text bold" etc).
Flags: needinfo?(ehsan)

Comment 6

4 years ago
(In reply to Mats Palmgren (:mats) from comment #5)
> Olli/Ehsan do you know about any efforts to standardize keyboard commands for
> "rich-text editing" elements? (e.g. CMD+B for "make selected text bold" etc).

Not that I know of.

But I disagree with Mats' position here.  Our feelings about what pages can do aside, this is definitely a regression which I don't think is acceptable.  Given how broken the editor component of all engines are, people handle these events in JS and do their own handling *all the time*.  This is not at all uncommon on the web today.
Status: RESOLVED → REOPENED
Flags: needinfo?(ehsan)
Resolution: INVALID → ---
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 862519
You need to log in before you can comment on or make changes to this bug.