Closed Bug 972790 Opened 6 years ago Closed 6 years ago

[Tarako] slow response when typing in new message

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

Other
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:-, b2g-v1.3T verified)

VERIFIED FIXED
1.4 S3 (14mar)
blocking-b2g -
Tracking Status
b2g-v1.3T --- verified

People

(Reporter: angelc04, Assigned: rudyl)

References

Details

(Keywords: perf, Whiteboard: [c=effect p= s=2014.03.14 u=] [SI-testing-blocker])

Attachments

(2 files)

STR:
1. Launch SMS
2. Add a new message
3. Tap on message body
   --> Keyboard appears after 2s.
4. Continuously typing on keyboard
   --> The input was delayed to be input to message body.
Summary: [Tarako] slow response when add new message → [Tarako] slow response when typing in new message
blocking-b2g: --- → 1.3T?
can we confirm on the latest build? 
and provide a video? thanks
Component: Gaia::Dialer → Gaia::Keyboard
Flags: needinfo?(waychen)
Flags: needinfo?(waychen) → needinfo?(pcheng)
can you work with partner on the keyboard performance acceptance? thanks
Flags: needinfo?(styang)
Attached video STR video
attached is a video. Tested on build 20140217032035.
Flags: needinfo?(pcheng)
Can you retest with bug 875963 and bug 972276?  I think those still need to be uplifted.
Depends on: 972276, 875963
Whiteboard: [c=progress p= s= u=]
Hi Marvin/Steven, the team suggests to turn off work suggestion on Tarako. Do you have concern for the final product? Thanks
Flags: needinfo?(mkhoo)
We disabled auto suggestion off. In terms of SMS, to make this perform better, we'd probably also need 972238. But that's too risky for 1.3t.
Whiteboard: [c=progress p= s= u=] → [c=progress p= s= u=] [SI testing blocker]
Hi Joe, also discussed with Bruce, he is PM owner for Keyboard, the conclusion is to turn it off specifically for 1.3t, m-c shall remain ON.
Flags: needinfo?(mkhoo)
Flags: needinfo?(styang)
Whiteboard: [c=progress p= s= u=] [SI testing blocker] → [c=progress p= s= u=] [SI-testing-blocker]
Sorry for misunderstanding, the turn off should be temporary and we should seek solution and fix for Production.

Vibration and Key sound should be enable and test for production.

Evelyn, could you look at this? thanks!
Flags: needinfo?(ehung)
We need QA to verify the issue again as comment 4 said - bug 875963 and bug 972276 may fix this issue. Rudy will work with QA, assign this bug to him.
Assignee: nobody → rlu
Flags: needinfo?(ehung) → needinfo?(atsai)
Assign to William, who's doing some related tests as well.
Flags: needinfo?(atsai) → needinfo?(whsu)
I'm trying to uplift bug 875963 and bug 972276 to v1.3t branch.

Joe,

Do you know if we need to make a specific patch to disable auto suggestion by default or the partner would do this on their own during its build configuration?

Thanks.
Flags: needinfo?(jcheng)
hi Rudy, it is currently disabled for Tarako but the decision is still to be made on whether we disable / enable suggestion by default but yes, if we can make it easily customizable, can you please provide the patch? Thanks
Flags: needinfo?(jcheng)
Bug 875963 and bug 972276 have been uplifted to v1.3t.
I'll check this tomorrow and see if the patch lands which fixes this.
Flags: needinfo?(jhammink)
Keywords: qawanted
Bug 969544 also got uplifted to try to improve the performance.
Depends on: 969544
In reply to comment 12:
The word suggestion and autocorrection could be simply disabled with this patch.
Or could be customized by the following guideline, since those are controlled by settings.

https://developer.mozilla.org/en-US/Firefox_OS/Developing_Firefox_OS/Market_customizations_guide#settings.json
Hi, Al and All,

Thanks for the reminder.
I will did the performance measurement after Rudy uplift whole related patches.

---------------------------------------------------------------------------------
Hi, Rudy,

Please mark this bug as "RESOLVED" after you uplift all patches.
I will measure and check whether these patches can help us address this problem.
If not, I would like to file other bugs to trace remaining work.
Thanks.
Flags: needinfo?(whsu)
Duplicate of this bug: 981505
Dear William,

Thanks for the reminding.
All the related patches have been uplifted. Please help re-evaluate this with suggestion and auto-correction turned off.

Comment 16 will be left as a reference, partner could decide if they want to take that patch (to turn off suggestion by default) or not.

Thanks.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Does this happen only in SMS or also in other apps? I'm thinking bug 972238 might be related.
Flags: needinfo?(whsu)
triage: - as this bug could be fixed already.
please open a new bug if needed and nominate 1.3T? thanks
blocking-b2g: 1.3T? → -
(In reply to Jan Jongboom [:janjongboom] from comment #20)
> Does this happen only in SMS or also in other apps? I'm thinking bug 972238
> might be related.

Hi, Jan,

Yes. This bug also happened on text/number fields of others app, like, contacts app, browser app, and e.me etc...
Thanks.

--------------------------------------------
Hi, Rudy,

Thanks for the help.
I will verify this bug later.
Flags: needinfo?(whsu)
Keywords: qawanted
Keywords: perf
Whiteboard: [c=progress p= s= u=] [SI-testing-blocker] → [c=effect p= s=2014.03.14 u=] [SI-testing-blocker]
Target Milestone: --- → 1.4 S3 (14mar)
Please note the symptom of  bug 857907 is quite easy to be reproduced with suggestion on, so I logged some debug info on that bug and mark it as dependency.
Depends on: 857907
(In reply to Rudy Lu [:rudyl] from comment #23)
> Please note the symptom of  bug 857907 is quite easy to be reproduced with
> suggestion on, so I logged some debug info on that bug and mark it as
> dependency.

I thought we were disabling the keyboard suggestion feature.  Is that something we need to support for release?
It's not my call, but if the patch we have in bug 982269 (remove all sync reflows in keyboard code) fixes the problem then we should definitely release with that patch + autocorrect enabled. My 2cts.
Sorry for the delay coming back.

I'm also seeing it resolved on today's build, as per William's comment.  

As per the original STR, I'm seeing ~1 sec for the keyboard to appear when tapping message body.
Flags: needinfo?(jhammink)
See Also: → 972774
Sorry for the late reply!
Here are the data I got.

* Test Steps:(Automation)
 1. Launch message app
 2. Tap pencil icon to edit a message
 3. Tap "Message" field
 4. Input a letter

* Disable auto correction & word suggestion
 1. 0.25 sec
 2. 0.17 sec
 3. 0.18 sec
 ~Average: 0.2 sec

* Enable auto correction & word suggestion
 1. 0.39 sec
 2. 0.46 sec
 3. 0.41 sec
 ~ Average: 0.42 sec

* Build information:
 - Gaia      cc0f31ec4509d5067bf155fd7ea38425dcbe39eb
 - Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/c20ed9f97159
 - BuildID   20140401004001
 - Version   28.1

Yes! Disabling auto correction & word suggestion can improve Tarako keyboard performance.
By the way, Bug 989268 had the same discussion.
Thanks.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.