Provide an easy way to dismiss about:feedback for good

VERIFIED FIXED in Firefox 29

Status

()

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: mbrubeck, Assigned: mbrubeck)

Tracking

(Blocks 1 bug, {ux-interruption})

Trunk
Firefox 30
All
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox29 verified, firefox30 verified)

Details

Attachments

(2 attachments)

Assignee

Description

5 years ago
From bug 787860 comment 12: a lot of users are complaining that about:feedback keeps appearing when they don't want it to.  This might be because the "Maybe later" link is the only obvious way to dismiss the initial prompt.

On the "happy" page from about:feedback, we show both "Maybe later" and "No thanks" options.  I suggest adding "No thanks" to the initial page also.
Assignee

Comment 1

5 years ago
This changes the footer of the "intro" section on about:feedback, making it identical to the footer of the "happy" section.
Attachment #8376311 - Flags: review?(mark.finkle)
Attachment #8376311 - Flags: feedback?(ibarlow)
Assignee

Updated

5 years ago
Blocks: 888144
Attachment #8376311 - Flags: review?(mark.finkle) → review+
Matt, can you post a screenshot please?
Assignee

Comment 3

5 years ago
Posted image screenshot
This looks fine to me. I still think we need to address the bigger issue of users being shown this screen repeatedly, even after they have rated Firefox. In https://bugzilla.mozilla.org/show_bug.cgi?id=787860#c12 I suggest that perhaps we should *only ever show this once* to users. 

The only way they would see it more than once is if they were to tap "maybe later", in which case we wait for some period of time and display it again.
Assignee

Comment 5

5 years ago
https://hg.mozilla.org/integration/fx-team/rev/2f7d8cae0854

(In reply to Ian Barlow (:ibarlow) from comment #4)
> This looks fine to me. I still think we need to address the bigger issue of
> users being shown this screen repeatedly, even after they have rated
> Firefox. In https://bugzilla.mozilla.org/show_bug.cgi?id=787860#c12 I
> suggest that perhaps we should *only ever show this once* to users. 
> 
> The only way they would see it more than once is if they were to tap "maybe
> later", in which case we wait for some period of time and display it again.

This is already the case, as far as we know.  We only show the screen when the user has launched Firefox exactly 15 times (unless they press "maybe later", which resets the launch counter to 0).  Our current theory for why users are seeing the prompt repeatedly is that they are pressing "Maybe Later", possibly because it is the only highly-visible way to dismiss the prompt and so they think it is the only way.
Assignee

Updated

5 years ago
Attachment #8376311 - Flags: feedback?(ibarlow)
https://hg.mozilla.org/mozilla-central/rev/2f7d8cae0854
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
Maybe we should uplift this to Fx29 while we can. It's a simple, low risk fix and has no strings.
I see 8 different items on input.mozilla.org over the last month complaining about the Feedback form and saying the "Maybe Later" doesn't work.

Some of these people say it's enough to make them move away from Firefox. Getting "No thanks" on the front page might help.
Comment on attachment 8376311 [details] [diff] [review]
add a "No thanks" link on the about:feedback intro

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Poor UX for users
User impact if declined: Upset users
Testing completed (on m-c, etc.): It's been on m-c and m-a for a while
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #8376311 - Flags: approval-mozilla-beta?
Attachment #8376311 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
"No thanks" link is present on the about:feedback intro on Firefox for Android 29 Beta 8, Firefox for Android 30.0a2 (2014-04-17) and Firefox for Android 31.0a1 (2014-04-17), so I will mark this bug as verified fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.