Closed Bug 972941 Opened 11 years ago Closed 10 years ago

Desktop client needs landing page for non WebRTC-compliant browsers on supported devices

Categories

(Hello (Loop) :: Client, defect, P3)

defect

Tracking

(Not tracked)

VERIFIED FIXED
mozilla33
backlog mlp+

People

(Reporter: RT, Assigned: rgauthier)

References

Details

(Whiteboard: [est: 1d][p=1])

User Story

As a non WebRTC browser URL clicker on Windows 7+, Mac or Linux, I get prompted to install Firefox so that I can place the call.

Approximate UX:

- Check if supported browser
- If not, display "Sorry your browser is not currently supported, please try using Firefox" (or similar) with download link.

Attachments

(1 file)

      No description provided.
You reach this page when clicking on a link using a non-WebRTC compliant browser.
This web page prompts that you don't have a WebRTC compliant browser and advises to install Firefox.
We want to make sure that we have a somewhat different message for users activating the link on iOS, since there isn't presently anything they can install to make use of the link -- something more like "Sorry, the device you're using isn't supported yet."
Need the specific UX here, maybe split this down into cases where old/non-compliant browsers versus items we just don't support yet.
User Story: (updated)
Flags: needinfo?(rtestard)
Flags: needinfo?(jboriss)
Depends on: 972024
Blocks: 972024
No longer blocks: 972014, loop_mlp
No longer depends on: 972024
@Mark I agree, we need another bug for the iOS scenario.
Flags: needinfo?(rtestard)
Summary: Desktop client needs landing page for non WebRTC-compliant browsers → Desktop client needs landing page for non WebRTC-compliant browsers on supported platforms
Summary: Desktop client needs landing page for non WebRTC-compliant browsers on supported platforms → Desktop client needs landing page for non WebRTC-compliant browsers on supported devices
Mark -- I'm assigning this to you as part of bug 972024.  Thanks.
Assignee: nobody → standard8
User Story: (updated)
Whiteboard: [est: 1d]
Priority: -- → P2
Flags: needinfo?(jboriss)
Blocks: 974895
Depends on: 986421
Component: General → Client
Updated patch here: https://github.com/mozilla/loop-client/compare/bug-972941

Currently it doesn't work consistently due to race conditions from data.ini taking too long to load when trying on the non supported browsers.
backlog: --- → mlp+
No longer blocks: 974895
User Story: (updated)
Blocks: loop_mlp
Whiteboard: [est: 1d] → [est: 1d][p=1]
Target Milestone: --- → mozilla32
Attachment #8414448 - Flags: review?(standard8)
Comment on attachment 8414448 [details] [review]
Landing page for non WebRTC-compliant browsers

The rough outline looks fine, and I believe it will fix the l10n issues I was seeing.

This should be tested (by hand) in chrome & safari during review, reloading a few times to ensure there's no display issues.

Passing review to Nicolas so I can focus on other things.
Attachment #8414448 - Flags: review?(standard8) → review?(nperriault)
Priority: P2 → P3
Comment on attachment 8414448 [details] [review]
Landing page for non WebRTC-compliant browsers

The patch looks good, r=n1k0. Please squash, rebase and land onto master with r=n1k0 added in the commit message.
Attachment #8414448 - Flags: review?(nperriault) → review+
Romain landed this earlier today:

https://github.com/mozilla/loop-client/commit/5f0c5903287d7fd30247f4e1ed316aaa31a982ac
Assignee: standard8 → rgauthier
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: mozilla32 → mozilla33
Confirmed this is working as expected on an iPhone and Firefox 20 on Desktop and Android.
Status: RESOLVED → VERIFIED
QA Contact: anthony.s.hughes
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: