Navigating to Geospacial site FF does not present the approval Button

RESOLVED INCOMPLETE

Status

()

Firefox
Untriaged
RESOLVED INCOMPLETE
4 years ago
2 years ago

People

(Reporter: dfern, Unassigned)

Tracking

28 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20140214])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8376595 [details]
FF No Permission.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.107 Safari/537.36

Steps to reproduce:

Navigate and open the site:
http://whatismyipaddress.com/w3c-geolocation
Notice that in the page it says:
"Please be patient while the browser attempts to determine your location and the map loads. Most browsers will prompt you for your approval before the map will load -- You must give your approval for this geolocation method"
But there is no place to approve.


Actual results:

The user does not get a button to approve use of the geolocation 


Expected results:

Like in IE the user should receive an approval button
Similar to bug: 908692
Electrolysis: Geolocation permission box doesn't open either
[testday-20140214]
(Reporter)

Updated

4 years ago
Whiteboard: [testday-20140214]
(Reporter)

Updated

4 years ago
Summary: Navigating to Geospacial site FF does not present the approval Box → Navigating to Geospacial site FF does not present the approval Button

Comment 2

4 years ago
[testday-20140214]
In windows 8 and firefox 28 beta 3 build this button appears. It appears exactly in the up in the left corner of the screen.
Hi dfern,

I have tested this issue on the latest Firefox release(43.0.4) and the latest Nightly(46.0a1) and in both cases the dialog appears in the up-left corner of the screen. However it seams that there is an error when you try to share your location from latest Firefox release. But Latest Nightly release seems to be unaffected. This means that a fix is on its way for the remaining issue.

Build ID: 20160105164030
User Agent:	Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0

Build ID: 20160107030235
User Agent:	Mozilla/5.0 (Windows NT 6.1; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0

Still could you please try to reproduce this on the latest release(43.0.4) and/or the latest Nightly (https://nightly.mozilla.org/) and provide the results?

Thanks,
Cipri
Flags: needinfo?(dfern)
Since the reporter didn't provide the requested information, I will mark this issue as RESOLVED INCOMPLETE. If you still encounter this problem, please feel free to reopen this bug, or file a new one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(dfern)
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.