Clicking "Restore Defaults" before the icons load in the Customize window causes it to break until you restart

VERIFIED FIXED in Firefox 29

Status

()

Firefox
Toolbars and Customization
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: justdave, Assigned: Gijs)

Tracking

(Blocks: 1 bug)

29 Branch
Firefox 30
x86_64
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox28 unaffected, firefox29 verified, firefox30 verified)

Details

(Whiteboard: [Australis:P3])

Attachments

(1 attachment, 1 obsolete attachment)

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:29.0) Gecko/20100101 Firefox/29.0

STR:
1) Click the menu dropdown
2) Click "Customize" on the bottom left
3) Click on "Restore Defaults" as soon as it appears, without waiting for the rest of the icons in the window to load.

Results:
1) Restore Defaults doesn't actually do anything
2) The icons in the left panel of the Customize window never load
3) Restore Defaults doesn't work and those icons never load, until you restart the app.

Stack trace from browser console:

"[CustomizeMode]" TypeError: aWindowPalette is null
Stack trace:
CustomizableUIInternal.getUnusedWidgets@resource://app/modules/CustomizableUI.jsm:1391
this.CustomizableUI.getUnusedWidgets@resource://app/modules/CustomizableUI.jsm:2764
CustomizeMode.prototype.populatePalette/<@resource://app/modules/CustomizeMode.jsm:567
Task_spawn@resource://gre/modules/Task.jsm:142
CustomizeMode.prototype.populatePalette@resource://app/modules/CustomizeMode.jsm:576
CustomizeMode.prototype.reset/<@resource://app/modules/CustomizeMode.jsm:874
TaskImpl_run@resource://gre/modules/Task.jsm:233
resolve@resource://gre/modules/commonjs/sdk/core/promise.js:118
then@resource://gre/modules/commonjs/sdk/core/promise.js:43
resolve@resource://gre/modules/commonjs/sdk/core/promise.js:185
resolve@resource://gre/modules/commonjs/sdk/core/promise.js:118
then@resource://gre/modules/commonjs/sdk/core/promise.js:43
resolve@resource://gre/modules/commonjs/sdk/core/promise.js:185
TaskImpl_run@resource://gre/modules/Task.jsm:242
Handler.prototype.process@resource://gre/modules/Promise.jsm:767
this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm:531
 CustomizeMode.jsm:56
"[CustomizableUI]" "findWidgetInWindow was passed an empty string." CustomizableUI.jsm:153
"[CustomizeMode]" TypeError: aWindowPalette is null

Updated

4 years ago
Blocks: 872617
(Assignee)

Updated

4 years ago
Whiteboard: [Australis:P3]
(Assignee)

Comment 1

4 years ago
Created attachment 8376767 [details] [diff] [review]
disable (undo) reset buttons at the start of Australis' customize mode transitions to prevent breakage,

This should do, I believe.
Attachment #8376767 - Flags: review?(bmcbride)
(Assignee)

Updated

4 years ago
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
(Assignee)

Comment 2

4 years ago
Created attachment 8376769 [details] [diff] [review]
disable (undo) reset buttons at the start of Australis' customize mode transitions to prevent breakage,

Actually, the undo reset button should be hidden at the end of customize mode instead of disabled. Oops.
Attachment #8376769 - Flags: review?(bmcbride)
(Assignee)

Updated

4 years ago
Attachment #8376767 - Attachment is obsolete: true
Attachment #8376767 - Flags: review?(bmcbride)
Attachment #8376769 - Flags: review?(bmcbride) → review+
(Assignee)

Comment 3

4 years ago
remote:   https://hg.mozilla.org/integration/fx-team/rev/dffffd86b592
Whiteboard: [Australis:P3] → [Australis:P3][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/dffffd86b592
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3][fixed-in-fx-team] → [Australis:P3]
Target Milestone: --- → Firefox 30
(Assignee)

Comment 5

4 years ago
Comment on attachment 8376769 [details] [diff] [review]
disable (undo) reset buttons at the start of Australis' customize mode transitions to prevent breakage,

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis
User impact if declined: people can break stuff by clicking 'restore defaults' really quickly after entering customize mode
Testing completed (on m-c, etc.): on m-c for a while
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #8376769 - Flags: approval-mozilla-aurora?
status-firefox28: --- → unaffected
status-firefox29: --- → affected
status-firefox30: --- → fixed
Attachment #8376769 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 6

4 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/e81d62bab6d0
status-firefox29: affected → fixed
(Assignee)

Updated

4 years ago
See Also: → bug 974481
(Assignee)

Comment 7

4 years ago
Backed out:

https://hg.mozilla.org/releases/mozilla-aurora/rev/62aa405444cd

because it relies on the undo button being renamed, which happened in bug 971626, which doesn't have approval yet and therefore isn't on aurora yet.
status-firefox29: fixed → affected
Depends on: 971626
Whiteboard: [Australis:P3] → [Australis:P3][dont land on aurora before bug
(Assignee)

Updated

4 years ago
Whiteboard: [Australis:P3][dont land on aurora before bug → [Australis:P3][dont land on aurora before bug 971626]
(Assignee)

Comment 8

4 years ago
Relanded now that bug 971626 has landed:

remote:   https://hg.mozilla.org/releases/mozilla-aurora/rev/fca9c79627e9
status-firefox29: affected → fixed
(Assignee)

Updated

4 years ago
Whiteboard: [Australis:P3][dont land on aurora before bug 971626] → [Australis:P3]

Updated

4 years ago
QA Contact: cornel.ionce
Verified as fixed using latest Aurora (build ID: 20140314004001) and latest Nightly (build ID: 20140314030202).
Status: RESOLVED → VERIFIED
status-firefox29: fixed → verified
status-firefox30: fixed → verified
You need to log in before you can comment on or make changes to this bug.