When history settings are customized, window menu continuously adds blank menu items

RESOLVED DUPLICATE of bug 1041808

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1041808
4 years ago
4 years ago

People

(Reporter: Yuhui, Unassigned)

Tracking

27 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8376678 [details]
customized History preferences

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20140212131424

Steps to reproduce:

1. Customize Preferences --> Privacy --> History as shown in the attachment.
2. Visit any website where cookies are required, preferably those where you have not already set Firefox to allow/block cookies.

See this thread in Mozillazine: http://forums.mozillazine.org/viewtopic.php?f=38&t=2786015&sid=db5cc0d08658b4c75840005681f5d16e


Actual results:

Empty menu items are added to the browser's Window menu, one for each site that tries to add a cookie.


Expected results:

No menu items should be added to the Window menu.

Comment 1

4 years ago
I am seeing this in Firefox 26 and 27 as well.

I have my privacy preferences set similarly.  See "Screen Shot 2014-02-17 at 02.14.18 am - cropped.jpg" attachment.

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:27.0) Gecko/20100101 Firefox/27.0
Build ID: 20140212131424
Version: 27.0.1

Comment 2

4 years ago
Created attachment 8376997 [details]
Screen Shot 2014-02-17 at 02.14.18 am - cropped.jpg

Comment 3

4 years ago
I have been getting this problem with Seamonkey 2.24 and 2.25 on both Windows 7 and Linux.

Comment 4

4 years ago
Roger's (SeaMonkey) Bug 992663 - Blanks in Window List from "Window" Menu Drop-Down
I've added STR to it.

In FF, is the 'Windows' menu-item specific to Mac?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

4 years ago
Status: NEW → UNCONFIRMED
Ever confirmed: false
I did not have to play with history entries. If you find this related to the cookie retention policy set to "ask for each cookie", it's a dupe of bug 970017
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1041808
You need to log in before you can comment on or make changes to this bug.