Closed Bug 973661 Opened 7 years ago Closed 7 years ago

[FTE] In FTE, when skipping PIN screen, there is no option to get that screen again when pressing back

Categories

(Firefox OS Graveyard :: Gaia::First Time Experience, defect)

x86
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.3+, b2g-v1.3 fixed, b2g-v1.3T verified, b2g-v1.4 fixed)

VERIFIED FIXED
1.4 S2 (28feb)
blocking-b2g 1.3+
Tracking Status
b2g-v1.3 --- fixed
b2g-v1.3T --- verified
b2g-v1.4 --- fixed

People

(Reporter: arcturus, Assigned: arcturus)

References

Details

(Keywords: regression, verifyme)

Attachments

(1 file)

While fixing Bug #969293 realised that if we skip the sim pin input, there is no way of getting that screen again when we press the back button.

So if we skip, go to wifi and then go back, we go back to the language selection and from then, the next step is again wifi.

IMHO, this should be a blocker, since we are missing the chance to enable data connection if we accidentally skip the first sim pin input.
blocking-b2g: --- → 1.3?
Last Working Environmental Variables:
Device: Buri
BuildID: 20140107004001
Gaia: ff5f06dd321f7d2bf4a5b311ded2c56e865d4f83
Gecko: 71ad7ff30010
Version: 28.0a2
Base Image: V1.2-device.cfg

First Broken Environmental Variables:
Device: Buri 
BuildID: 20140108040200
Gaia: b7a7191f761933fd4878227488c75d09f5ba890c
Gecko: cf2d1bd796ea
Version: 29.0a1
Base Image: V1.2-device.cfg

Last Working Gaia/First Broken Gecko: Issue Does NOT Reproduce
Gaia: ff5f06dd321f7d2bf4a5b311ded2c56e865d4f83
Gecko: cf2d1bd796ea

First Broken Gaia/Last Working Gecko: Issue DOES Reproduce
Gaia: b7a7191f761933fd4878227488c75d09f5ba890c
Gecko: 71ad7ff30010
QA Contact: jzimbrick
Noemi

Can you please find assignee here?
blocking-b2g: 1.3? → 1.3+
Flags: needinfo?(noef)
(In reply to Preeti Raghunath(:Preeti) from comment #2)
> Noemi
> 
> Can you please find assignee here?

Francisco Jordano will have a look at it.
Assignee: nobody → francisco.jordano
Flags: needinfo?(noef)
Hi,

after a bit of looking at the code, I realised that is done in purpose.

I mean, we do have a back button in the top, and a skip button, when pressing the back button (left up corner), we go back, and then on the next step we ask again for the pin.

If we press the skip button we won't ask again for the pin, and that's what I mean that's intentional.

Flaging Michael Henretty for more info about this. Michael is that the supposed behaviour?
Flags: needinfo?(mhenretty)
Hi Francisco,

This is not done on purpose. When I landed the DSDS changes, I specifically wanted to fix this scenario.
https://bugzilla.mozilla.org/show_bug.cgi?id=926347#c41

It looks like the problem is that I fixed this for the DSDS case, but not for single sim. If you would like, I can take a look here.


https://github.com/mozilla-b2g/gaia/blob/9b800479527806bf46eace7988c7d19604645a42/apps/communications/ftu/js/sim_manager.js#L194
Flags: needinfo?(mhenretty)
Attached file Pointer to PR 16522
Attachment #8379834 - Flags: review?(mhenretty)
Comment on attachment 8379834 [details] [review]
Pointer to PR 16522

LGTM. Let's land when we get green.
Attachment #8379834 - Flags: review?(mhenretty) → review+
Landed on master:
https://github.com/mozilla-b2g/gaia/commit/8576b712fce2cce4a7be94b8e7ee4522f8057988
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment on attachment 8379834 [details] [review]
Pointer to PR 16522

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Simple patch to avoid loosing the data 3g panel in FTU
[Bug caused by] (feature/regressing bug #):
DSDS feature
[User impact] if declined:
Huge, user can skip step to add pin and never get it back in the FTU, not being able to configure the data connection of the device
[Testing completed]:
Unit test passing, will ask for qawanted to verify
[Risk to taking this patch] (and alternatives if risky):
Not risky
[String changes made]:
Attachment #8379834 - Flags: approval-gaia-v1.3?(fabrice)
Asking for qawanted to check the solution in single sim and dual sim devices.
Keywords: qawanted
Target Milestone: --- → 1.4 S2 (28feb)
(In reply to Francisco Jordano [:arcturus] from comment #10)
> Asking for qawanted to check the solution in single sim and dual sim devices.

For QA verification we generally user the keyword "verifyme", switching to that.
Keywords: qawantedverifyme
This issue is fixed on buri v 1.4 Mozilla RIL

Environmental Variables
Device: Buri 1.4 MOZ RIL
Build ID: 20140224040201
Gecko: https://hg.mozilla.org/mozilla-central/rev/31113754db3b
Gaia: ffb527b84594396ed611edf0a8a5a130d60a742f
Platform Version: 30.0a1
Firmware Version: V1.2-device.cfg

The user is able to navigate back to the "Enter SIM PIN" after skipping the page.
Status: RESOLVED → VERIFIED
Attachment #8379834 - Flags: approval-gaia-v1.3?(fabrice) → approval-gaia-v1.3+
Uplifted 8576b712fce2cce4a7be94b8e7ee4522f8057988 to:
v1.3: ea36c42945009591c95fe4436148daa8b89ac6da
Verified for v1.3T. This issues does not reproduce on the latest v1.3T Tarako build:

v1.3T Environmental Variables:
Device: Tarako v1.3T MOZ RIL
BuildID: 20140530014002
Gaia: e68858693b71d917c9c5ee7e215f7ceea04635f7
Gecko: 1945abae19ff
Version: 28.1
Firmware Version: SP6821a-Gonk-4.0-5-12

-

User is now prompted for their SIM Pin when they hit back from the WiFi screen after skipping the initial attempt.
You need to log in before you can comment on or make changes to this bug.